Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

(Topic created on: 27/08/18 15:47)
Bobik
Apprentice
Options
TV

Hello,

 

I am trying to fix my parents Samsung TV F6500 which has stopped connecting to Internet since a few weeks. Here is my diagnosis: The TV won't connect to Internet using wifi or Ethernet throught their usual provider. When I use my 4G phone as an access point, the TV connects normally.

 

These are the solutions I have already tried and that didn't work:

- Reseting the ISP's router + changing it's IP adress

- Factory reset of the Samsung TV (using the Auto-diag menu and the secret menu that you access pressing different buttons on the remote)

- Changing DNS to 8.8.8.8 or 8.8.4.4.

- Updating the firmware

- Calling the ISP's hotline

'

My questions are :

- Is it possible to do a factory reset that includes the Network connections?

- Has anybody had the exact same issue as my parents?

- Even after the factory reset, the TV continues to say that the firmware is up to date, is it possible to remove the updated firmware?

 

I am out of options and the Smart Hub is now useless. Any help would be greatly appreciated!

 

 

 

1 ACCEPTED SOLUTION
Solution
150DotAve
Apprentice
Options
TV

I've tried many different "fixes" to try and resolve the problem. Came across a trhead that suggested holding down the power button on the remote unit the TV reboots. Tried it and it worked. TV has been connected since without issue.

View solution in context

519 REPLIES 519
Sylake
First Poster
Options
TV

Every device you have uses an individual IP address to connect to the internet. When I had this problem I found that two samsung tvs  were using the same IP address so only one would connect to the internet.  I went into the internet settings on the tv that would not connect and added a number at the end of the IP address and have not had a dropped connection since.  Just need to make sure you are not using an IP address assigned to another device in your home network. It has been months since I did this.

Pulanski
Apprentice
Options
TV

Thanks for this but I didn’t have to do this in the end. Someone on the community said that I should press the power button u TIL the Samsung logo appeared and the red light flashed. This seems to reconnect the tax to the internet. It has worked every time so far. Still shouldn’t have to do this though. Fed up with Samsung!!!

0 Likes
Reply
Pulanski
Apprentice
Options
TV

Hi thanks for this! Thisworks for me every time I switch the TV on now. At least I don’t have to reset the network connections and put in the WiFi code every time!

0 Likes
Reply
Miggz
First Poster
Options
TV

Did you ever find a solution? If have the same issue. I end up having to reset the network every time. 

0 Likes
Reply
paul1277
Black Belt 
Options
TV

@Bobik wrote:

Hello,

 

I am trying to fix my parents Samsung TV F6500 which has stopped connecting to Internet since a few weeks. Here is my diagnosis: The TV won't connect to Internet using wifi or Ethernet throught their usual provider. When I use my 4G phone as an access point, the TV connects normally.

 

These are the solutions I have already tried and that didn't work:

- Reseting the ISP's router + changing it's IP adress

- Factory reset of the Samsung TV (using the Auto-diag menu and the secret menu that you access pressing different buttons on the remote)

- Changing DNS to 8.8.8.8 or 8.8.4.4.

- Updating the firmware

- Calling the ISP's hotline

'

My questions are :

- Is it possible to do a factory reset that includes the Network connections?

- Has anybody had the exact same issue as my parents?

- Even after the factory reset, the TV continues to say that the firmware is up to date, is it possible to remove the updated firmware?

 

I am out of options and the Smart Hub is now useless. Any help would be greatly appreciated!

 

 

 


Have you reported it to your retailers , if not do it straight away. If your Internet works ok on another device then its a problem with the TV. If it worked ok one day and then stops,  that says to me it is a fault with the TV. If it is less than 4 weeks I would suggest asking for a replacement as it should work perfectly without having to jump through hoops. If over 4 weeks ask for an engineer to fix it so it works as advertised. 

Paul. 

Carlloyd
First Poster
Options
TV

Hi all 

 

I've been experiencing the same lack of internet issue since July 2018.

 

After reading the various responses  I contacted Samsung support who advised I upgrade my Tv's firmware. This didn't resolve the problem.

I then tried using mobile phone as a hot spot and the internet connection  started working again. I reverted to my home network and the internet connection failed with a DNS error.

 

I manually entered a public DNS address of 208.67.222.222 and this has fixed the issue.

My TV is now working properly again with full internet access.

 

Carl.

Mst197
First Poster
Options
TV
Carl,
That worked a charm. My virgin media guy didn't have a clue.
What you have to do is
Network settings
Change get IP settings automatically to get manually
Make a note of the existing IP,DNS Subnet settings and enter manually then enter the digits Carl added.
0 Likes
Reply
rd1864ss
First Poster
Options
TV
I tried that did not work for me.
0 Likes
Reply
Tino46
Explorer
Options
TV

Hi

I appreciate your post and for potentially identifying a solution to the problem.

To help everyone is possible to post the full set of settings so I can ensure all the settings are the same. I spent some considerable time yesterday trying many different numbers and configurations, still to no avail. Excuse my ignorance if some of these would be different (due to my connection details, etc), not that techy, but hoepfully know enough to get round this issue.

For ease can you complete the following fields:

 

MAC Address (Is this my own number or are they generic? - mine starts off f8:77:b8:......):

IP Address (Shoud this be the 208.67.222.222?):

Subnet Mask (Currently set to 255.255.0.0):

Gateway (Currently 0000) :

DNS Server (Currently 8888):

 

Really would appreciate this info and would surely help loads of others who are experiencing the same issue.

I will then try this and you may be an absolute HERO!!!

Many thanks

 

 

0 Likes
Reply
TessM
Moderator
Moderator
Options
TV

Hey @Tino46 , if you would like, you can reach our Audiovisual Specialist to have a look into this with you and confirm the right settings. They can be reached on: 0333 000 0333.

0 Likes
Reply
Sterling
Observer
Options
TV
The Mac is pertinent to your device. Separate 2.4 and 5Ghz with different names on your router. If you are using a Netgear, there are known issues with 2.4Ghz using Netgear routers. In addition, 2.4 the bandwidth is 11mb half duplex which really means 5Mbs, your TV will start cutting out on the 2.4. Move all big items like TVs etc to the 5Ghz and small items like weight scale, smart outdoor plugs to use the 2.4
0 Likes
Reply
Sylake
First Poster
Options
TV

My Samsung tv suddenly stopped connecting to the internet.  I changed the IP address and it connected.  I think it was trying to use the same IP address of my other Samsung tv and that was causing a conflict so it would not connect.

0 Likes
Reply
rski
First Poster
Options
TV

I have separate SSIDs for 2.4 and 5 GHz, and the TV had still grabbed two addresses the first day I turned it on (I just bought it this week). I run my own DHCP server, so I've pegged the MAC of the TV to a fixed address (which I do with most of the devices that use DHCP on my network - makes it easier to keep track of them!), and we'll see if the TV stops consuming new addresses. It is still responding to the original two addresses that it consumed - which means that the TV firmware is at fault, it should stop responding on the earlier addresses when it gets a new one. (This would cause the DHCP leases to time out and the addresses to get returned to the pool.) This is why the router continues to keep the old addresses blocked. Another answer might be to set the DHCP lease time short, but if the TV continues to renew the leases on all of the addresses that it 'owns', this will not help (and is also an error in the TV's firmware).

Yes, I have been in IT and tech support for many years. 🙂

TVLover
First Poster
Options
TV

So for the layman on this thread...do you have a suggestion other than the "press and hold the red power button until TV reboots"???  (I'm just a girl who wants to watch her Netflix and Amazon Prime apps...lol).

0 Likes
Reply
Greg8491
Explorer
Options
TV

You are right... there are some complicated solutions on this thread, but the easiest I've found (being a non-expert) is the remote power button solution,  or turning the TV off and back on at the power strip behind the set to hopefully encourage it to connect to the internet.  Doubtful that This is a Samsung design feature tho!!!  Haha....

0 Likes
Reply
2Smart
First Poster
Options
TV

Nope, nothing other than the Red Button....I , like you, just want to watch me apps ! 

 Nothing tech savvy or clever about me. Type in my issue, read the forum and follow suggestion. Just so happened the easiest one did the trick. No good asking me how ....not a clue....it just worked for me....😃 actually makes a change , instead of the technical ones 😁.

 

Greg8491
Explorer
Options
TV

Yep, you've got it right!  Good luck with the solution!!

0 Likes
Reply
Annicx
Apprentice
Options
TV

To be honest, this is the best fix I've found. Samsung clearly have a 'deny everything' policy and I'm reluctant to start messing too much with everything else in case I make it worse!

0 Likes
Reply
rski
First Poster
Options
TV

I can confirm that with my 'fixed' DHCP address, the TV is stable and has stopped consuming other DHCP addresses on my net. Using a static IP on the TV should accomplish the same thing. I may test this when I move the TV from wifi to wired (after I rearrange my home network, probably during the Xmas holidays).

cliftonws74
New Member
Options
TV

I was able to get the WIFI to work and not drop. To do this I had to:

 

1. Log into my home router and allocate a static IP address to the WIFI. 

2. Go to the firewall section of the router and add an exception to the firewall to allow that static IP to pass through the firewall at all time. 

3. Enable MAC Filtering for the Samsung TV and add the TV to the MAC Filtering list.

4. Extend the DCHP lease to 99 days

 

This allowed the WIFI to work. I also have a ethernet cable hard wired to the back of the TV. I took similar steps here, but the smart hub diagnostics continued to say that the ISP was blocking the TV even after I added the hard wire IP to the firewall passthrough. I really want the TV on the ethernet and will continue to work but these steps have worked successfully so far. I have not had the TV very long and debated taking the TV back for a refund due to this issue. 

 

Just as FYI, I have used a Roku and Firestick without any issues. 

0 Likes
Reply
rd1864ss
First Poster
Options
TV

Log into your router? I never heard of that how is that done?

0 Likes
Reply