Support

Open search

Can't switch digital output audio format on Netflix app

Highlighted
First Poster

Yeah, doesn't work for me either. Tried forcing an app update and a TV firmware but neither updated and it made no difference. 

Highlighted
Explorer

Samsung replaced my motherboard today (because of my ongoing general troubles with HDMI ARC between my Q70 and my Denon AVR).

 

The weird thing was that Netflix app audio worked perfectly fine on the old OS version 1047 that came with the motherboard. After a wireless upgrade to the current OS version 1356 it doesn't work anymore. 

 

I wonder when this will eventually be resolved .. in the meantime I watch Netflix through my connected Mac mini (albeit in PCM, not Dolby Digital format).

Highlighted
First Poster

Hey Guys, sorry but that was a false alarm. Seems I was able to change output 2 times but it goes back to greyed out after TV is switched off. I checked software versions and there was no updates recently. I'll let you know if I figure out sequence to unlock this feature

Highlighted
First Poster

I really don't think this is a hardware issue since DD+ works fine with any other app in Samsung TV. Only Netflix gives me problems (and weirdly the integrated ambient mode as well)... Hope they fix this soon otherwise I'll have to use an external player only for netflix which is really lame.

 

Q70 and Denon Receiver here as well and loud buzz sound on netflix.

Highlighted
First Poster

My Denon AVR will decode DD+ from Netflix just fine over a regular HDMI input. It's just the built-in Q90 Netflix app with DD+ over ARC that is the problem

Highlighted
Observer

Same issue here. Nothing helps. My Q60 is stuck in DD+ when running the Netflix app which my audio receiver does not support. So the Netflix app is useless to me now. This definitely happened with a TV firmware update and clearly is not a Netflix app issue but an issue with the tv itself. I am so very disappointed in Samsung.

Highlighted
Apprentice

I just a few days ago got an automatic TV update... same issue now.  I'm on 1356.2 firmware.

 

Netflix app is the only one where I have the issue, and only started this past week.  Same as everyone has described, locked into DD+ using ARC to my receiver.... which doesn't understand DD+.

 

Awful static noises making the Netflix app useless. 

 

Has anyone had luck switching to the optical output for audio? 

ARC is really flaky on my Q70R to begin with and it seems like some of this is compounded by the support on any ARC that doesn't meet HDMI 2.1: https://denon-uk.custhelp.com/app/answers/detail/a_id/6333/~/arc-%2F-earc-compatibility

 

I've been beyond frustrated more than a few times with this TV.  I hold out hope that they're working to fix this, but if it stays like this, I'll be returning the TV for an LG OLED.

Highlighted
First Poster

Yes, an optical cable has provided an audio solution for me. Of course I lose DD+ but at least I have dolby digital. I just bought a low cost optical cable off Amazon 

Highlighted
Apprentice

Chatted with Samsung support today (I am in the US) and they were at least able to confirm that this HAS been reported as a known issue.

 

I tried to be persistant (politely), to ask that my instance of the issue be added to the number of cases.  I said several times that the severity of the issue is high because a function of the product is 'broken' as a result of this firmware release.

 

Unfortunately, the only answer that can be given is that we all wait for the next firmware release (with no timeline of when that will be) and cross our fingers that the issue is addressed at that time. 

 

I tried to illustrate as well that there are reports of the issue dating back several months already, but all it does is

1. make me hope that the fix is further along as a result, and

2. worry that the issue will get dismissed as 'incompatible hardware' or something and never resolved

 

Netflix support wasn't too much help, although they'd confirmed (vaguely) that there haven't been release updates to the Netflix app on the Tizen platform (Samsung SmartTV) that would have changed the behavior.

 

Highlighted
First Poster

I have had the same issue with Netflix sound using the app on my 6month old Samsung TV and my Denon receiver over ARC. As others have mentioned this has been since an update some months ago. 
However, switched the Netflix app on this evening expecting to have to change from my home cinema system to the TVs own speakers and miraculously it was working. At last, I thought. I watched the new Eurovision film in Dolby 5.1 and all was good. I have since left the app, watched some regular TV and then launched the app again. Frustratingly, back to the same problem as previous. Has anyone else experienced this? 

Top Liked Authors