Open search

Can't switch digital output audio format on Netflix app


I have a qe55q60r connected to a reciever. The sound works great, however when I turn on the Netflix app i get bad noise as described in Netflix-sound-not-working-on-UE50NU7400-with-digital-output.

According to that issue, the solution is to switch the digital outpu audio format to PCM, and it indeed worked for me for a while.

Since few days ago, I guess there was an automatic firmware update, however, not sure, when the Netflix app is on, the digital outpu audio format in the settings menu is grayed out with the option Dolby Digital+ and I can't change it, so I can't get rid of the noise. On the TV speakers this option is set to PCM and sound works well.

Can anyone please help me solve this? Or at list help me get the previous firmware version so I can see if it is a firmware issue? 



same problem here, I tried to reset smart hub, didn't help.

on support chat now. no idea what the problem is, or how to fix it.

First Poster

Same problem here. Samsung soundbar works for every app but Netflix, support could not help


I got the the same issue with my 

QE65Q60RATXXC. Super frustrating! every other app lets me choose betweed PCM and DD or DD+ but Netflix does not. Locked to DD+. Strange thing when unplugging my Hdmi cable from the rwceiver the sound works for like 30 second with pcm before it turns back to DD+. I have yet to figurer out a way to stop this from happening. Worked perfectly a couple of weeks ago. And since my old pioneer reciever does not support DD+ it does not work


I have got the same problem (using a Samsung Q70 connect via HDMI ARC to my Denon AV). I believe it must be related to the Digital Output Audio Format which is set to Dolby Digital+ (my Denon cannot process this audio format), which I can't change to Dolby Digital or PCM when I am running the Netflix app. All other apps (eg Spotify) work fine. Strangely enough, this was working until a few days ago and suddenly it won't anymore !? Any ideas or any feedback from Samsung?


There are a few posts on this. Common problem. 

I have spoken to Netflix and Samsung about this. 

I have 2 screens of the same model. One was upgraded and now gives no audio on Netflix, the other is fine. 

This is a problem with the 1351.3 firmware. 

no response from Samsung. 


Do you know where to find the older FW version?


Can't downgrade firmware.....



Please let me know if you hear any constructive feedback from Samsung. The issue might quite likely be related to a recent software upgrade since it worked perfectly fine until a few days ago. I wonder how we can make them acknowledge that a number of people are experiencing this issue so that they escalate this to their internal software engineering team!?


I contacted Samsung customer service here in Hong Kong yesterday to describe the issue to them, but they just followed some sort of script and advised me to turn off my TV for one hour and turn it on again (needless to say, that's totally useless advice).


Let's hope there'll be a solution soon!

Top Liked Authors