Open search

Smart home App - not working



since he last update of the smart home App (iOS version) the app does not work at all.

At the beginning it did crash every time during "connecting to server" - after Deinstallation and Installation it does not connect anymore to the smart home device (air condition in my case). He smart device itself is connected to Wifi and can be reached via PING....

i neeed help 😉


127 REPLIES 127

Dear Samsung team,


For a change the Samsung Smart Home application stopped working for me since two days +. It was working fine since 14-12-2017 unfortunately not anymore. it is stuck in the device authentication screen and stays there without any luck of getting authenticated. 


Steps of troubleshooting I have already done:


(1) Reset of router

(2) Reset of samsung smart wifi kit device connected to the AC 

(3) Removed the application from the iphone X and installed clean one from the appstore

(4) login with credentials works fine also the AC is recognized only the authentication fails or loops althoug I click on the AP button for one second.


Can you please have a look on your side or explain how to trouble shoot the current outage?


Thanks and best regards





Dear Ants,


Thanks a lot for your message! Glad to hear things are well. Unfortuntely to hear that things are migrated the smart home application worked so well untill two days ago. I have just tried the Smart things application unfortunately that doesn't work either. I have posted pictures in the below link:

You can see that the application is connected to the wifi

It couldn't add the device is the error

neither autodetect

The wifi hub is not supported it said

I made also a picture of my smart home device between the AC and the WIFI just for you to know.


Please let me know how to proceed further.


Thanks and best regards,


FYI This is the manual of the wifi kit that is used by my AC

Samsung device used is Air to water heatpump split hydro AE160JNYDEH

No worries @cool_vibe_tesla. And thanks for the info and screenshots there too! :smiling-face: :thumbs-up-sign-emoji-modifier-fitzpatrick-type:


Just to cover some other things:


  • What's the current version of iOS on your iPhone X?
  • What's the SmartThings app version you're using?
  • What's your ISP (and router make, if you know)?
  • Any issues with your Samsung Account linked to this all - and does logging out and back into it have any joy for you for getting the devices connected?

Dear Ants,


Thanks a lot for your prompt response! Please find the requested information below:


IPhone X IOS version 12.1.4


SmartThings app version: 1.6.28-225


I am using an f-secure sense IOT router:


The ISP is using a PPPoE connection over Ubiquiti hardware:


There are no issues with the samsung account it works fine I did logout and login into the application. Tried to connect the AC again without any luck. Same errors as in the above screenshot. 😕


Please let me know how you prefer to proceed.


Have a pleasant evening and keep in touch!


Best regards,


Thanks @cool_vibe_tesla:thumbs-up-sign-emoji-modifier-fitzpatrick-type:


I've asked a couple of my colleagues who are more knowledgeable about the SmartThings-appliance setup than I am to take a look at this. I'll let you know what their advice is when they reply to me. 

@AntS thanks a lot! I am eager for your response. I think it is important to highlight that all was working like a charm for a long while within the smart home application. Have a great weekend and keep in touch.



@AntS  Dear AntS, Not sure if something has been done one Samsung's side but luckily the old Smart home application is up and working like a charm again since Saturday as per below screenshot. Thanks a lot for your support much appreciated!


Best regards,




Top Liked Authors