Support

Open search

Samsung Galaxy Buds with Windows 10 laptop

Highlighted
SOLVED
First Poster

Do the Galaxy Buds work well with a laptop that has Windows 10 as its OS?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator
Moderator
@Max1996S: Yes, no problem. If your laptop has Bluetooth then please enable it and open the Galaxy Buds case to begin the pairing process. If you experience any issues then please ensure that you disconnect the buds from any other devices you have connected to. Hope this helps.

View solution in original post

29 REPLIES 29
Highlighted
Moderator
Moderator
@Max1996S: Yes, no problem. If your laptop has Bluetooth then please enable it and open the Galaxy Buds case to begin the pairing process. If you experience any issues then please ensure that you disconnect the buds from any other devices you have connected to. Hope this helps.

View solution in original post

Highlighted
Apprentice

not mine: it is configured as HEADSET and got me a mono audio.... it's anoying... and i dont know how to fix! Theres is only  channel...

 

Anotação 2019-08-18 213631.jpgAnotação 2019-08-18 213656.jpg

Highlighted

Did you ever find a solution to this issue?

Highlighted

My earbuds didn't work in Windows 10. Perfectly in my Galaxy but not in windows: Metalic noise, mono sound, continuous disconect... technical support sayd to me this morning they do not guarantee operation on windows

Highlighted

Ok, I have the same issues. I appreciate your responce!

Highlighted

My was like this too. But, I've updated my notebook and the trouble ended. 

 

Try install the last updates and desconnect 100% and connect again the buds. 

 

And, after all, check the output, because windows install 2 mods: headphone and earphone for the buds.

Highlighted

You are right, two mods: 1 stereo and other Handfree. In the first connection the laptop connect automaticly with stereo mod, when disconect this mod dissapear and I only can use the handsfree. With this mod I can`t up or down volumen so I need to discconect bluetooth and start again.

I already update de system and disconect the buds... but the problem is still here : (

Highlighted

please, try:

 

1) update your buds, via app

2) try update the drivers.

 

ps1: when i say disconnect the bufds, i say delete it from your note and reconnect like it ws a new one.

 

if none of this helps, i am sorry. i am no longer capable to help you. 

 

ps2: i was having this problem and i saw in foruns it was a windows problem and have to wait an update. the update came and my problem was resolved. so, i didnt do anything especial, understand? Hope the best for you! 😘

Highlighted

Hi, do you know what date was the update? if it was just drivers or another thing?

Top Liked Authors