Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Galaxy watch 4 taking calls in Bluetooth headset not working

(Topic created on: 13-12-2021 04:10 PM)
1995 Views
sparkyram
Apprentice
Options

Hi.. when ever I take any calls on phone I can see an option to transfer the phone to my galaxy watch 4 and I am able to take calls in watch loudspeaker.even though watch is connected to galaxy buds pro the calls always works in loudspeaker...i have enabled both calls and audio output to my headset in the watch settings..tried with bose 700 headphones and it's the same issue.. any solutions?

83 REPLIES 83
kinjalc
First Poster
Options

I have the same problem to pair Realme buds with Galaxy watch 4.

Spotify, YouTube Music works fine with the buds that are connected to watch 4 but calls do not. The settings on watch 4 for buds clearly say it is allowed for calls and audio. But whenever using calls - the audio is converted to use the watch's loudspeaker instead of the buds. 

0 Likes
mcolson1590
Student
Options

Ditto.  I'm able to get calls over the loudspeaker.  But I want the calls over the headset attached to the watch.  I walk away from my phone but want music to keep going, which is why I want to pair the headset to my watch and not directly to the phone.  I'm fine with missing calls when I'm away from my phone.

Gonzo505
Journeyman
Options

Replying to his indeed solved the problem of answering calls through the watch and get the call in the buds but if your solution is applied you can then not listen music from the watch and get the call in the buds from the watch at the same time. So, its either getting call in the buds through the watch or listening music.. But there has to be solution for listening music and other media contain from the watch through the buds and then when there is a call one should be able to simple answer the call from the watch and get the call in the buds. I am having Samsung Galaxy 4 Classic (no LTE version) and Tronsmart Spunky Beat wireless buds. Is there solution for that? There has to be because watch settings indicate so....   

0 Likes
SpirosG
Apprentice
Options

Hi, i have the same problem with my galaxy watch 4 classic (bluetooth) and my buds pro.
There is no way to send calls sound from the watch to the buds pro when am making or receiving  a call through the watch.

This needs to be resolved Sammy!

Gonzo505
Journeyman
Options

After I conducted additional check-ups over offered solution by Ish1990, the issue is actually easy to solve (actually there is even no issue to be solved at the first place). Namely, you need to connect earbuds with your phone only (assuming that your phone is connected to your watch) and if you want to listen to for example Spotify you open and start spotify on your phone (you will get it on you watch too if you enable on your watch option to control media from your watch) and in case someone is calling you, music will automatically stop and you will be able to answer the call from your watch and get the call into your earbuds. After the call ends the music will automatically continue to play. So, earbuds are not suppose to be connected with your watch but with your phone only and everything will work then as a charm.

xXLARXx
Explorer
Options

No, I've tried to make a call with earbuds connected to the phone and the call still comes through the speaker on the watch.

0 Likes
Gonzo505
Journeyman
Options

I forgot to mention that you only have to have watch sees the buds but with sound and calls turned off on the watch (see the picture) and, of course, with Bluetooth on.  Screenshot_20220121_105439_settings.png

xXLARXx
Explorer
Options

Thank you, I'll give these steps a try. 

0 Likes
Gonzo505
Journeyman
Options

Ok, and let us know did you succeeded in resolving the issue...

0 Likes
Gonzo505
Journeyman
Options

This option on the watch should also be off like in the picture bellow (and to remind this is all related to non LTE watches)... SGW bluetooth.JPG

0 Likes