Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy Watch 4 'Couldn't copy your Google Accounts'

(Topic created on: 21-06-2022 09:22 PM)
Mati Sklepowicz
First Poster
Options
Wearables

Hello,

I have read countless threads about this problem and tried most solutions and this feature is still yet not working for me.

 

Samsung A21 (Bought in the UK)

Galaxy Watch 4 (Bought online via a foreign website)

 

What happens?

Whenever I try to copy my google account from my phone to my watch, my phone says 'Couldn't copy your Google Accounts', whilst my watch is constantly loading on 'Check your Phone'. 

After pressing 'Next' on my watch to add a google account, my phone screen flashes black for 2 seconds and nothing appears after that. 

I have tried: clearing caches, resetting both my phone and watch, turning off developer settings, turning wifi on and off, etc.

Keep in mind, I do not have a google account linked for Watch Settings > Account and Backup > Google Account, as it does not allow me to add it.

 

Help is much appreciated.

 

 

2 REPLIES 2
Easye
First Poster
Options
Wearables

I have got the same issue since the update of the galaxy watch.

Tried already the things you mentioned and additionally used a second phone, 2 other Gmail accounts and disabled every biometric feature and also to step authentification. I am not in a family group.

To sum it up: the watch 4 is bad

Mati Sklepowicz
First Poster
Options
Wearables

A few days after making this post, I contact Samsung Support and these are the solutions I got:

- Reset both watch & phone several times
- Turn off WiFi on phone

- Turn off Biometrics, Security & Screen Lock on phone

- Make sure to not be using any other google accounts on your phone

- (IF UNDER 13) Make sure to make your account 13+
- Log out and log back in Google Account
- Check for updates for Google Play Services & clear cache
- Clear cache for Galaxy Wearable & Google Play Services
- Remove Google Account from device and add back
- Turn off Developer Options (if on)

- Reset WiFi

 

For me, I just had to wait a few days and reset both devices a few times and it worked.

0 Likes