Support

Open search

iPlayer HLG/UHD HDR on Samsung’s J and K Series TVs

Highlighted
Pathfinder

So, of the nigh on 400 TVs supported in BBC iplayer for the Blue Planet II  HLG episodes none are from Samsung. Oh joy. 

...

Moderator edit: Original thread title was "Blue Planet 2 HLG - No Samsung". With the OP's permission, the title was changed on 12/03/2018 to accurately reflect the dominant theme of the thread as it has progressed. If the reader would like to know more about the HLG format, please check out the BBC's page and FAQ's on it here: http://www.bbc.co.uk/rd/projects/high-dynamic-range Thank you, AntS.

4,827 REPLIES 4,827
Highlighted
Pathfinder

The Roku landed today so thanks all on this thread for the recommendation and advice.  Can't wait for 3.30pm now!

 

What's everyone's preferred Picture settings? After watching the UHD test loop I had to peg the Roku to 4K HDR 30Hz as the 60Hz was way too jittery on my KS7000. Anyone else find the same?

Highlighted
Voyager

You will want to enable the Roku setting for auto switching of display rates. The bbc feed is at 50hz which is why it looks so good (smoothness)

 

I need to have a fiddle with some of the other TV settings like backlight and dynamic contrast today. Not sure I’m quite getting the best image available - saw the France game at a friend’s yesterday who has an LG panel. Didn’t have the same issues with “over” brightness that I had with Spain v Portugal. 

Highlighted
Apprentice

@dunwell wrote:

You will want to enable the Roku setting for auto switching of display rates. The bbc feed is at 50hz which is why it looks so good (smoothness)


Seen 50hz mentioned a couple of times.. Do I just leave it on the default Auto 4K/HDR 60Hz?

 

Had a look at all the settings and the only other option with 4K and HDR was 30Hz?

Highlighted
Voyager

Put the resolution to the highest possible (4k/60hz)

 

There’s a setting in advanced which is “automatically adjust display rate” or similar. Make sure that’s enabled. 

Highlighted
Voyager

@dunwell wrote:

You will want to enable the Roku setting for auto switching of display rates. The bbc feed is at 50hz which is why it looks so good (smoothness)

 

I need to have a fiddle with some of the other TV settings like backlight and dynamic contrast today. Not sure I’m quite getting the best image available - saw the France game at a friend’s yesterday who has an LG panel. Didn’t have the same issues with “over” brightness that I had with Spain v Portugal. 


One way to slightly compensate for the over-brightness is to set the TVs gamma to -3, and reduce the backlight a few clicks. That’s the only changes I’ve made from the default movie HDR settings other than turning off Auto Motion Plus.

Highlighted
Helping Hand

@dunwell wrote:

Put the resolution to the highest possible (4k/60hz)

 

There’s a setting in advanced which is “automatically adjust display rate” or similar. Make sure that’s enabled. 


Yes this is a must as it sends it correctly at 50Hz.  I understand that the gamma curve is not correct but the screen is not too bight for me.  Looks stunning.  Only one downside.  On mine the Roku iPlayer app has the screen going off (not the sound) for a few seconds every few minutes or so.  This is not just the UHD stream but iPlayer generally.  Its a bit distracting but the picture is so much better that the standard HD that I put up with it.

Highlighted
Pathfinder

@dunwell wrote:

Put the resolution to the highest possible (4k/60hz)

 

There’s a setting in advanced which is “automatically adjust display rate” or similar. Make sure that’s enabled. 


Excellent, many thanks for the help. Looks fantastic now!

Highlighted
Navigator

After being away since Friday morning this is the first time I’ve been able to try the Roku to access the World Cup in UHD on iPlayer. 

It looks simply stunning, far better than 4k without HDR like Sky at the moment. I am generally very happy with my KS7000 panel so this is a great work around. The BBC have done good, fair play. 

Highlighted
Voyager

@tarbat wrote:

One way to slightly compensate for the over-brightness is to set the TVs gamma to -3, and reduce the backlight a few clicks. That’s the only changes I’ve made from the default movie HDR settings other than turning off Auto Motion Plus.


I'm getting the same PQ as Friday once more.   Done what you suggest and turned colour up to 70 once more (from 50).  Not as as good as yesterday but still awesome

Highlighted
Explorer

Argos delivered my stick at 3:50 managed to get set up before kick off. Looks good. My mts says it's hurting her eyes

Top Liked Authors