Support

Open search

Can't switch digital output audio format on Netflix app

Highlighted
Apprentice

I have a qe55q60r connected to a reciever. The sound works great, however when I turn on the Netflix app i get bad noise as described in Netflix-sound-not-working-on-UE50NU7400-with-digital-output.

According to that issue, the solution is to switch the digital outpu audio format to PCM, and it indeed worked for me for a while.

Since few days ago, I guess there was an automatic firmware update, however, not sure, when the Netflix app is on, the digital outpu audio format in the settings menu is grayed out with the option Dolby Digital+ and I can't change it, so I can't get rid of the noise. On the TV speakers this option is set to PCM and sound works well.

Can anyone please help me solve this? Or at list help me get the previous firmware version so I can see if it is a firmware issue? 

 

Thanks! 

54 REPLIES 54
Highlighted

Hi all,

 

Just leaving this here in case it helps anyone:

 

1 - Exit Netflix App

2- Select a.n.other source e.g. Live TV or HDMI Source

2- Settings>Sound>Expert Settings>Digital OutputAudio Format -> Two out the three formats will be available (PCM & Dolby Digital - Dolby Digital Plus will be Greyed Out). Whichever format is currently selected, change to the other e.g PCM>DD or DD>PCM

3 - Exit the menu

4 - Complete a "Cold Boot" by pressing & holding the Standby Key on the remote control until the Boot logo appears (This performs the same process as turning the TV Off & On at the Mains but from the comfort of your sofa - Note: For Frame TV owners I'm afraid you'll still need to pull the mains)

5 - Select Netflix & Playback

 

(I've been told that Samsung and  Netflix are working together to enable a complete fix which will be included in a software update - but we don't have a timescale on that.)


 Say "Hello!" to the Community in The Introduce Yourself Thread.


Highlighted

Same thing here with RU8005 and older Pioneer receiver. TV says Atmos compatible even when it's not and Netflix forces DD+ and receiver doesn't understand this. This started after update maybe 2 months ago. Customer service just wants to reset my TV over and over again when clearly we all know that this is bug. Wish I could get older firmware back but it seems impossible.

Highlighted

Tried this with my UN58NU6080FXZA. First, there is no standby button. Used hard reset. Was able to switch modes fro. PCM to Dolby on SirriusXM app, followed all steps and hard power off using power strip switch. Turned back on and switched to netflix and Pioneer amp and same problem: DD+ is selected and option are disabled. Can only watch Netflix using tv speakers

 

Highlighted

Same problem here...Netflix forces Dolby Digital PLUS which my receiver does not understand. Worked fine earlier. All other apps works great with Dolby Digital (HBO, AmazonPrime etc...) Please let me know if there is a work around....

Highlighted

Anyone had any luck with this issue? Or heard anything back from Samsung? 

Highlighted

Just wanted to add that I'm getting the same issue on my new UE55RU7400. I just spent all day setting it up, switching HDMI cables to my amp and even digging out an optical cable to see if that would fix it, then I came across this forum conversation. Luckily we have Sky Q so we can watch Netflix on there until Samsung and Netflix come up with a solution, but it's pretty poor software assurance and testing. 

Highlighted

I don't think Samsung will ever fix this. It's been a while and all they have done is deny the problem.

 

Besides, we all already spent the money buying the Tv, after that point they really don't care anymore. 

 

Lesson learned to all us. Never spend money on ANY Samsung product ever again. 

Highlighted

I have the same issue with my Q90R and the Netflix internal app using DD+ audio via ARC to my Denon AVR. The funny thing is my 2113ci AVR decodes Dolby Digital + just fine when the source (Netflix on my Blu Ray player) is connected to the AVR via standard HDMI input. Its just the DD+ over ARC that is jacked up. So it's not an issue with my AVR

Highlighted
Hey Guys, seems there is an update available which fixes the problem. I'm able to select audio output now. As it was "silent" update I'm assuming it was Netflix app problem.
Highlighted

Nope....still doesn't work for me, silent updates, noisy updates, ***** updates...

Top Liked Authors