Support

Open search

BBC iPlayer not working on UE32ES5500K TV Smart Hub

Highlighted
SOLVED
First Poster

For a few months BBC iPlayer has not working been working on our UE32ES5500K TV Smart Hub. If we click on the Button, it just goes to a black screen. 4OD, ITV and other services are working OK. It won't let me Uninstall the app, so I can't reinstall a new version. It says its on Version 2.02603. If I try and run it from the App Store screen, it still goes to a black screen. Any suggestions?

86 REPLIES 86
Highlighted

Hi @Floss92. Try 1234 or 4567. Hope this helps!

Highlighted

This worked for me too.  Someone should send it to the bbc if they haven't already

Highlighted

BBC Iplayer worked until two or three weeks ago. I have unplugged and reset several times but still cannot get beyond the 'Loading' screen.   Any thoughts?

The TV Model code is LT32E390S

Highlighted

Try this it worked for me. 

 

Hi all. Like many others out there I suddenly found myself not being able to access Iplayer on my 6 year old Samsung TV. Mine was not on the list of TV’s provided on the BBC website and the problem began to occur when the BBC Insisted that I now sign in to use Iplayer. Basically after 2 weeks of mucking about with trying this and trying that I appear to have stumbled upon my own personal solution.

 

*** Navigate to the BBC News app on the smart hub and click on it. It told me to update the software and 10 seconds later Iplayer was working. ***

 

Hopefully it will not disappear again and this solution helps some of you get back to watching what you pay for. 

Highlighted

Hi Castlehead,

I had this problem on my ES8000 hopefully my solution will work for you. I followed rjbweb's post of 11/10/2018 to get back to factory state and then reloaded as if from new, also take a look at my post 3 weeks ago which expands a little on the rjbweb post.

Regards Packhamp

Highlighted

Tried iPlayer again on my ES7000, after 2 months of not loading,  and it loaded without problem.

Did not reset or change anything , so whatever the problem was appears to have been fixed for me anyway

 

Highlighted

I am also having a similar problem with BBC iplayer. I have tried resetting the TV to factory settings, but this as made no difference. I note one of the suggestions mentioned a technicians menu, how do I find that menu? The TV model is UE40H6400

Highlighted

iPlayer now loads OK but a message says it needs flash to play - any advice?

Highlighted
New Member

I have an F8000.  After signing up for the first time, iPlayer just showed me a black screen.  This worked for me:

Press Menu, Select 'Smart Features', find and select 'Reset Smart Hub' - enter your pin (see other threads on what this might be - I knew mine 🐵 ).  Wait.

It will remove installed apps and accounts...  and re-add its 'required' ones - I ended up with some new ones, as well as 'changed' ones.  iPlayer has since worked a number of times.

Highlighted

I too had this problem on my 2014 UE40 television and the above solution worked well. Thank you

Top Liked Authors