Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Hello, I have this weird problem that plagued my s22 and now s23 (stock ROM latest one Ui 5,1 s9110). I am wondering if anyone

(Topic created on: 08-05-2024 10:31 AM)
219 Views
Umka
Apprentice
Options

Hello,

I have this weird problem that plagued my s22, s23 and now s24  (stock ROM latest updates installed)
I am wondering if anyone has found a solution to this.

The problem:
When i go to Samsung Gallery on my Galaxy s23 and click and Synchronize Gallery with OneDrive, i am getting an error saying
SERVER ERROR OCCURRED. PLEASE TRY AGAIN LATER

I am aware of the workarounds, OneDrive photos backup feature backups photos from Samsung phone without problems. But it is not synchronized. I want it to be synced so that if I delete a picture from OneDrive it is also deleted from the Gallery, and vice versa, if i delete something from gallery, i want it to be deleted from OneDrive as well.

I have looked for solutions on other forums, but nothing i could find worked for me. Here is what I tried - maybe it will help someone
1) Logout from you Onedrive, Logout from Samsung Galaxy account. Wipe cache and data from OneDrive app in Settings>Apps reboot and re login to both Samsung Account and OneDrive
2) Create new Onedrive Account and Samsung Account
3) Reboot to Recovery and Wipe cache.

On the other hand, Backup feature and File syncing in Samsung Files app works just fine with existing settings.
Why is that MyFiles app has not problem syncing with OneDrive while Gallery app gives an error?

Could you please let me know if there is a solution?
I apologize if this has been answered before, I could not find an answer on this forum, but if there is one, kindly please give me a link.

THANK YOU

Screenshot_20230501_155011_Samsung Cloud.jpg

2 REPLIES 2
Robin999
Samsung Members Star ★
Options
Have you tried removing apps and services access from your Microsoft account?

Try this,

Remove both your Samsung account and Microsoft account from your device.

Next, log into your Microsoft account (preferably from a PC). Tap or click on the 'Privacy' tab. Scroll down to 'Apps and Services, tap on 'View app access details'. From the list, remove both 'Samsung' and Samsung Cloud'.

On your phone, add both your Samsung and Microsoft accounts. This should prompt the 'allow permission' warning, which you should grant access and will hopefully allow your phone to talk to the Microsoft servers.
Umka
Apprentice
Options

I have tried removing apps clearing cashe and wiping even from recovery. I tried buying new phones 5 times.\

Finally SOLUTION - it seems like my other samsung account (i do not remember creating, probalby was automatically created when setting up new phone) was tied to microsoft account and that caused a conflict.

too bad stupid error messages do not tell you something like "Your account is already used or linked to a different microsoft account", but give you a highly deceptive "Server error try again" message.

 

So if you have this problem - you need to find your other samsung account, login, and unlink your microsoft account. There is no way to do this from microsoft side as far as i know.

 

I only stick to smasung cause i do not want to go iphone road. Oh my god i wish there was more real competition in this market like old days. 

 

0 Likes