Open search

860 EVO 250GB causing freezes on AMD system




I bought 860 EVO 250GB 2.5" SATA few days ago (it came with the latest firmware) but there seems to be some sort of incompatibility with AMD 9xx chipsets. I have ASRock 970 Pro3 which has 970 NB + 950 SB, no additional storage controllers. I installed Windows 10 64 bit on it, then Magician, ran the "Performance Optimization" option there and left RAPID off since it says it may cause conflicts with AMD/AsMedia controllers. The problem is that Windows hangs at random times (it's not that often but it's annoying). For example, if it happens while there is a YouTube video running in the background, the sound continues and I can open a new tab in the web browser but the website won't load, I can't minimize the browser, if I click on the start menu button with the mouse, the menu won't come up, the task manager won't load when I press Ctrl + Shift + Esc and if I click on too many things everything freezes for 1-2 minutes, then goes back to normal. Also, everytime this happens, there are some CRC communication errors appearing in the SMART status. At first I thought it's a bad SATA cable, although I used the same cable with and HDD for 2 years and no such things occured, so I tried with another SATA cable and the result was the same. I upgraded the BIOS of the motherboard to the latest version, reset the CMOS, turned off any IDE legacy and power saving options for the storage, there is an option "AMD AHCI BIOS ROM" in the BIOS of the MB which also did not resolve the issue whether it's turned on or off.


What I found as an easy way to reproduce the issue is to run CrystalDiskMark, it hangs everytime at the 4KiB Q8T8 write test. Another scenario is to run virutalbox with ubuntu VM, for example - the PC hanged on both installation and update of ubuntu 16.04. Basically, you can reproduce the issue by putting the SSD on 9xx chipset AM3+ motherboard with FX CPU and then run CrystalDiskMark (I tested with version 6).


I also tested it on 2 Intel systems - one HP desktop PC with i3-3220  and one old HP laptop (with Intel T6570 CPU) and I didn't observe this issue on them. 


My specifications are:

ASRock 970 Pro3 (the first version not the R2.0 one)

AMD FX-6300 3.5GHz

11GB RAM DDR3 1333MHz

Samsung 860 EVO 250 GB SATA

Hitachi Ultrastar 2TB (HUA723020ALA640)


If you can come up with a fix, either new firmware or software workaround in Windows, it will be appreciated.





My long story short, I've replaced the evo ssd with another, which behaved exactly the same. At least using storahci drivers it's stable, but C7 errors keep accruing, and writes are crippled. Interestingly, it works perfectly fine on the asmedia controller, though slower, and without full support of things like virtualization.

I've finally replaced the Samsung 860 Evo with Crucial MX500 and the magic happened! No more issues of any kind on the SB950 controller using storahci drivers. I'll next update to amd drivers, just to check the difference, but it works fine as it is.

Both samsung ssds went back to amazon with a detailed 1-star review of the drives. Shame on you Samsung engineering!!

Exactly like others said. I am running Linux as well, so it took me a while to figure out it is 860 EVO (I have two, so ruled out it is not only the first faulty, I tried to find other causes, which wasted more time). Luckily I have 970 EVO in the system and that worked OK for now. Need to order more though, didn't plan it as the main storage.

This is a big waste of time. AMD / Samsung should simply mark their products as imcompatible to save everyone's time.

With basic driver AHCI 1.0 from Microsoft  working without problems.

But still It is a piggyback from samsung...

When I used the Microsoft AHCI driver, things seemed to work, but CRC errors were still building up in the SMART data. I'm not sure if that is an issue long term or not.

Update today March 27, 2019.

Using the Inland Professional SSD 120gb

from Microcenter

SKU 410936
Mfr Part# 349381
UPC 618996723140
Which is a real cheap SSD gave me these speeds.ssd.JPG

I just ran CrystalDiskMark . Note the version top of the picture, and the size of the drive left. I have almost filled the drive. This is THE drive I mentioned before.. that was the 'pos' drive.

I use this drive as my main SSD. I am pondering on getting a Crucial mx500 250gb or maybe another Inland Pro.. the price is just to cheap. I have not followed other threads or took note if anyone was having issues with Win 10 drivers. I am using Win 7 64bit right now.

3 web pages open when I ran the test. 

Notice the scores of inland professional 120 amd chipset drivers mar 27 2019..JPG



As far as the 9-series and below chipset versions from AMD are concerned:

- There were lots of issues and bugs due to "performance" vendor-specifc drivers that were never resolved ... there are chipset level bugs like SB950 cannot use MSI (Message Signalled Interrupts) ... and then there are driver issues like with RAID drivers, any activity to probe the status of disk can cause the system to hang or even crash

- After the latest driver (AHCI win 8 and above ... went missing ... AMD started recommending the "generic" Microsoft Drivers for stability (note that even though driver date might be 2006, it is an updated driver as seen from the win build version in the driver version string) ... one can still try the driver version (for win 7 ... though win 10 can use it as well) or (for win 8 and above) as these are mostly well liked ... for RAID drivers there might be similar options


So, one can try different driver versions or get an add-in card with a known good chipset!




I have absolutely no problems with SB950, no instabilities, no crashes whatsoever. That is using SSD Crucial drive and 4 Seagate HHDs. The only system wide serious problems I had where when the Samsung drive was connected.

Seems like you're blaming both AMD and Windows drivers for all problems. We all know AMD and MS are not perfect, but your logic is backwards. Crucial drive works perfectly fine. Are you saying the Samsung drive is so special both AMD and Microsoft should've created special drivers for it? 

Hello Again!


You seem to have misunderstood me! I meant to say that there can be a number of reasons for the problem but one is unlikely to get a fix due to the low chance of getting vendor specific updated drivers from AMD ... why AMD and not Samsung? Because AMD abandoned their chipset driver development in my opinion ... they were overwhelmed at that time (2015) ... it was difficult to balance performance vs stability  ... I did not mention the drive itself because it works for some people obviously since it is so highly rated ... it is also a question mark whether or not the issues highlighted below were ever fixed in the generic driver from Microsoft??? (links to wikipedia as original sources are mostly dead),_M770,_780x,_M780x,_79...)


See also: SB950 Product Errata


These lines are also present in the Installation Guide for the Magician software:

"Sometimes on AMD PC with AMD and ASMedia storage controllers it was found that  the IOs takes a longer time to complete. In such cases if Rapid was enabled, it may get automatically disabled due to such IO errors.  It may display "Rapid is in inactive state".  User has to reboot the PC to enable the Rapid back.


10) If multiple iterations of Read and Write are performed, RAPID mode may become inactive due to system internal errors on some of the AMD / ASMedia Controller or Driver. "


The fix other than the obvious one of not using this particluar drive that I could come up with is to either try a number of drivers to see if one works or to get an add-in card if this drive is to be used with a chipset known to work with this drive!


I myself have a system with the SB950 southbridge ... would have liked to see this drive work as well because I was looking to get one some time ago especially after trying out an older model one from Samsung ... fortunately I installed some other brand's ssd because I had no idea back then of these issues!







I had the exact same problems, both with Windows and Linux.

After some digging, I found out that there seems to be an incompabilty between the AMD SB710/750 chipset and newer Samsung drives when using NCQ.

There are two ways to fix this:

1) Disable AHCI in the BIOS and switch to IDE

2) Disable NCQ only


Option 2 should be prefered because AHCI without NCQ is still better than pure IDE.


Disable NCQ on Windows: (see Falcosoft's answer!)

Disable NCQ on Linux: Use grub parameter "libata.force=noncq"


After disabling NCQ, all my CRC problems vanished.

Hope this helps.


Just wanted to suggest checking a setting called AHCI Link power management. A guide is available at below link: I had similar issues with an Intel 330 ssd. The setting basically tell the drive very often that it should go into a sleep mode, which can cause issues if the drive doesn't handle the commands properly. Drives also use memory cache and temporary SLC mode flash as landing area for writes; the aggressive power saving commands could stress it too much. The setting would benefit the laptop users, by saving a bit of battery, but if it's used in a desktop or in laptop with power plugged in, it's not a very useful option.
Top Liked Authors