Open search

860 EVO 250GB causing freezes on AMD system




I bought 860 EVO 250GB 2.5" SATA few days ago (it came with the latest firmware) but there seems to be some sort of incompatibility with AMD 9xx chipsets. I have ASRock 970 Pro3 which has 970 NB + 950 SB, no additional storage controllers. I installed Windows 10 64 bit on it, then Magician, ran the "Performance Optimization" option there and left RAPID off since it says it may cause conflicts with AMD/AsMedia controllers. The problem is that Windows hangs at random times (it's not that often but it's annoying). For example, if it happens while there is a YouTube video running in the background, the sound continues and I can open a new tab in the web browser but the website won't load, I can't minimize the browser, if I click on the start menu button with the mouse, the menu won't come up, the task manager won't load when I press Ctrl + Shift + Esc and if I click on too many things everything freezes for 1-2 minutes, then goes back to normal. Also, everytime this happens, there are some CRC communication errors appearing in the SMART status. At first I thought it's a bad SATA cable, although I used the same cable with and HDD for 2 years and no such things occured, so I tried with another SATA cable and the result was the same. I upgraded the BIOS of the motherboard to the latest version, reset the CMOS, turned off any IDE legacy and power saving options for the storage, there is an option "AMD AHCI BIOS ROM" in the BIOS of the MB which also did not resolve the issue whether it's turned on or off.


What I found as an easy way to reproduce the issue is to run CrystalDiskMark, it hangs everytime at the 4KiB Q8T8 write test. Another scenario is to run virutalbox with ubuntu VM, for example - the PC hanged on both installation and update of ubuntu 16.04. Basically, you can reproduce the issue by putting the SSD on 9xx chipset AM3+ motherboard with FX CPU and then run CrystalDiskMark (I tested with version 6).


I also tested it on 2 Intel systems - one HP desktop PC with i3-3220  and one old HP laptop (with Intel T6570 CPU) and I didn't observe this issue on them. 


My specifications are:

ASRock 970 Pro3 (the first version not the R2.0 one)

AMD FX-6300 3.5GHz

11GB RAM DDR3 1333MHz

Samsung 860 EVO 250 GB SATA

Hitachi Ultrastar 2TB (HUA723020ALA640)


If you can come up with a fix, either new firmware or software workaround in Windows, it will be appreciated.





What OS are you using, Swift42? What driver (AMD or Microsoft)? Is that registry tweak still valid for Windows 10?




The best solution is:
Disable 860 EVO on AMD platforms
  :smiling-face: :winking-face:


I'm sorry, but there is a better option if you cannot throw either the 860 or the AMD computer to the bin. In Windows 10, when using the default Microsoft SATA driver, create a text file with the following data and save it as .reg.

Windows Registry Editor Version 5.00


That will disable the NCQ in the Windows driver for all SATA controllers (you can do the same for your specific HW ID if you have several SATA controllers) and it will avoid the CRC SMART errors in the 860. It has been tested in an ASUS1215B laptop and it works perfectly.


If you prefer to install the AMD SATA driver (in Windows 10, also valid for Windows 7), do the same with this data:

Windows Registry Editor Version 5.00



I hope this helps many people with AMD controllers. I contacted Samsung technical support and they just disimissed me with no solution. I had to find out the different registry entries in the Microsoft driver and understand which one disabled the NCQ. Luckily, it was easy to find and test!




Siento discrepar sobre la calidad por ahora de mis dispositivos de memoria sólida o NVMe of this manufacturer and I wait to continue similar at now.


Also I can speak about chips, but not at the moment.


I have some experience with that and AMD systems, I can tell and I have a relation with other case, forced timmings a bit and Rapid Mode ON. I don't know if it's your case sorry, never was the mine, but you never will have problems with HDDs with AMD or Intel devices and with Samsung or other too (we undestand about).


I would like to continue with yours, I need time for others, thinkings in other places as Space :thumbs-up-sign-emoji-modifier-fitzpatrick-type::smiling-face:


Thanks for the info and let me try if I have a litle bit more for you that I will translate and read yours carefully and time :birthday-cake:


Thanks all and @ll bye


I have just arranged return of my 1Tb 860 to Amazon 2 months after explaining the issue. ONE thing that REALLY annoys me is Samsung don't put out any warning about this incompatibility. I love Samsung, most of my stuff is Samsung, but this really is just so wrong. To go on selling stuff which can potentially ruin your machine and all it's data is just so wrong.

I have ASUS M5A99X EVO R2.0 mobo, and have tried everything to get this drive working safely but it just has to go back. It DOES NOT WORK! I've done all the rolling back of drivers I can take. Samsung, Please take note (finally perhaps). You know that you should not legally be selling products that don't fit their description, and although you don't explicitly say the 860 is compatible, the assumption of compatibility is there, and the sale is in European law illegal without a denial of liability for use with AMD chipsets. If it doesn't work, tell the sellers and buyers. This is a can of worms you leave open at your own risk Samsung. The law applicable is 'Fit for Purpose' and this is not.





I fully agree :thumbs-up-sign-emoji-modifier-fitzpatrick-type:


I also agree, there is no excuse for the poor customer support provided by Samsung. But using the registry tweaks I proposed in a previous post makes the SSD usable with an AMD controller, which is something that should have been proposed by Samsung as a workaround for AMD systems. I personally use the 860EVO in an ASUS 1215B laptop with no problems at all after applying the registry tweaks. If the speed is reduced it is something that I could not notice in my system.



The "registry tweak" you proposed is not a solution. You're disbling NCQ which degrades the performance, in essence limiting advantage of having SSD at all. It's like removing an infected tooth. Sure, the pain will go away, but you'll have less teeth to chew your food with. If you eat small pieces, it won't bother you much.

But for those who expect to get the performance they're paying for, this drive is a failure for AMD compatibility. Simply go with another manufacturer. I did, and never had to look back.


“The "registry tweak" you proposed is not a solution”

I never said it was a solution; it is only a workaround that can make both devices to coexist in the same system without any harm and a limited performance loss.


“in essence limiting advantage of having SSD at all”

That is not true at all! My SSD is still performing almost 2 orders of magnitude faster than any mechanical HDD in random read/write operations, even with the NCQ disabled. Moreover, the sequential transfers are almost unaffected by the registry tweak. You can test that by enabling/disabling NCQ in your healthy system, no matter what SSD you have. Specifically in my system, due to its age, the benefit of NCQ is even smaller than in newer SATA controllers. In addition, AMD has not released SATA drivers for Windows 10 (the Microsoft standard drivers are recommended), which does not seem a good practice anyway. The release of new drivers should add those registry tweaks for specific drive+controller combinations (like in the default Microsoft driver) to avoid hardware failures, and that is something that neither AMD nor SAMSUNG have done in this case. Shame on them!


“But for those who expect to get the performance they're paying for, this drive is a failure for AMD compatibility.”

Totally agree. It is a total lack of support, and it should be warned by SAMSUNG. It is something that could have been solved with a simple SSD firmware update, if SAMSUNG have had the will to do so.


I have an 860 EVO 1TB attached to an MSI Tomahawk motherboard with the B450 chipset. I run Linux. I experienced the same CRC errors reported here. However, I believe (fingers crossed) that I have a workaround to keep using the Samsung SSD. The MSI motherboard has 6 SATA ports. The first four are served off the B450 chipset, but the last two connect directly to the Ryzen CPU. By changing my SATA cable to SATA5 or SATA6 I don't have to use the B450 chipset with the SSD. The only negative for me is that this motherboard won't support an M.2 SSD if either SATA5 or SATA6 are in use. For the longer term this will be an issue, but, for now at least I'm back in business.

Top Liked Authors