Support

Open search

860 EVO 250GB causing freezes on AMD system

Highlighted
SOLVED
Apprentice

Hello,

 

I bought 860 EVO 250GB 2.5" SATA few days ago (it came with the latest firmware) but there seems to be some sort of incompatibility with AMD 9xx chipsets. I have ASRock 970 Pro3 which has 970 NB + 950 SB, no additional storage controllers. I installed Windows 10 64 bit on it, then Magician, ran the "Performance Optimization" option there and left RAPID off since it says it may cause conflicts with AMD/AsMedia controllers. The problem is that Windows hangs at random times (it's not that often but it's annoying). For example, if it happens while there is a YouTube video running in the background, the sound continues and I can open a new tab in the web browser but the website won't load, I can't minimize the browser, if I click on the start menu button with the mouse, the menu won't come up, the task manager won't load when I press Ctrl + Shift + Esc and if I click on too many things everything freezes for 1-2 minutes, then goes back to normal. Also, everytime this happens, there are some CRC communication errors appearing in the SMART status. At first I thought it's a bad SATA cable, although I used the same cable with and HDD for 2 years and no such things occured, so I tried with another SATA cable and the result was the same. I upgraded the BIOS of the motherboard to the latest version, reset the CMOS, turned off any IDE legacy and power saving options for the storage, there is an option "AMD AHCI BIOS ROM" in the BIOS of the MB which also did not resolve the issue whether it's turned on or off.

 

What I found as an easy way to reproduce the issue is to run CrystalDiskMark, it hangs everytime at the 4KiB Q8T8 write test. Another scenario is to run virutalbox with ubuntu VM, for example - the PC hanged on both installation and update of ubuntu 16.04. Basically, you can reproduce the issue by putting the SSD on 9xx chipset AM3+ motherboard with FX CPU and then run CrystalDiskMark (I tested with version 6).

 

I also tested it on 2 Intel systems - one HP desktop PC with i3-3220  and one old HP laptop (with Intel T6570 CPU) and I didn't observe this issue on them. 

 

My specifications are:

ASRock 970 Pro3 (the first version not the R2.0 one)

AMD FX-6300 3.5GHz

11GB RAM DDR3 1333MHz

Samsung 860 EVO 250 GB SATA

Hitachi Ultrastar 2TB (HUA723020ALA640)

 

If you can come up with a fix, either new firmware or software workaround in Windows, it will be appreciated.

 

Regards,

Martin

51 REPLIES 51
Highlighted

What's the registry command to enable the ncq back? Ty

Highlighted

bump

Highlighted

Depending on the change that you did, you can just remove the affected registry values using regedit and reboot:

 "SingleIO" (this one may have contained information for other controllers, you should restore the backuped value that you should have done when you changed the registry in the first instance).

Delete with no problems:

"NcqDisabled"

"AmdSataQueueDepth"

"AmdSataNCQDisabled"

 

Highlighted

Before everything, I sincerely thank About_blank for his investigation because I would have become crazy without him.

 

Short story : block the AMD update as featured on this page if you are about to install Windows 10 on a  860 Pro linked to an AMD 990FX/SB950 chipset board with the AMD // ASUS chipset drivers.

 

Long story :

 

Motherboard : Asus Sabertooth 990FX Rev 2.0

Processor : AMD Phenom IIX6 1100T

SSD : Samsung 860 Pro 1 TB

 

Well, I decided to install a brand new legal copy of Windows 10 Pro (with DVD) on my brand new SSD Samsung 860 Pro (yes, new in 2020 because I bought a sealed one to someone who had never opened it ^^).

 

And very soon, the computer started to freeze without being able to do anything. I browsed the web with my phone, restarted the computer several times, tried new parameters in the Bios... I wondered what could cause such freeze : the new firmware obtained in Magician ? An update ? Bios 2901 of my motherboard ? Avast ? The custom audio driver ? W10Privacy ? I did not know at all. I tried several times to open the device manager to uninstall the bad driver but I had not even the time to reach any program in the computer because it freezed in 5 seconds after login !

 

I also tried to find the Microsoft driver itself on internet, without success. I wanted to use it on a USB flash disk in repair mode of Windows because I am pretty sure I had done this once with Windows 7 but I could not figure how to do this with Windows 10, so I gave up...

 

As I did not want to have both W7 and W10 on my previous HDD, I reinstalled all W10 a second time on the 860 Pro with the DVD (destroy the two recent partitions to do so). I did not risk much as I was installing from scrap. But I did restoration points. And then I went to the updates. And I FOUND IT : Advanced Micro Devices, inc driver for AMD SMBus, about to be installed ! I instantly paused the updates and looked for how to block THIS update. And this is how I came across this page and it saved my computer. I keep the Microsoft driver like all of you, but I don't care much about that. My PC works... For now...

Highlighted

Hi everybody,I wish know if anyone have now a problem with samsung SSD's 2,5" and the new Ryzen 3900 X or 3950 X plateforms ? Best regards, chris 

Highlighted
Observer

11GB memory? That is your problem right there.

Highlighted

Similar experience.  Samsung Magician prompted last week to update itself then update firmware.  I did the Magician update, no problem, and then started the firmware update and left it running. Next morning the PC would not turn on.  I've stripped the motherboard (Asus tuf gaming 570 plus) down to no disks, no DVD, processor (Ryzen 3600), one stick of memory in DIMM A2, USB keyboard and mouse.  Removed CMOS battery and shorted the jumpers.  Tried to restore mobo bios from USB - absolutely dead still.  The LEDs on the mobo flash in sequence but end stuck on "boot".  

 

Its a £200 mobo, so I don't want to junk it.

Highlighted

I have the mobo, what I did was connected the 860 Evo 1tb to the Asmedia controller (grey sata ports as opposed to brown) sata port and I can now run the Samsung magician benchmark in 2 mins. 

Highlighted

Hi swagat, Would you please give the manufacturer and model number of your mobo? I'm uncertain of what you have. Thanks.

Highlighted

asus sabertooth 990fx r2.0

Top Liked Authors