Open search

Smart home App - not working

TracyR Moderator

Me again!




What error messages (if any) are you getting when using the app?



Say "hello!" and
Introduce Yourself, or virtually hangout in the Samsung Lounge


Dear Tracy,


Thanks a lot for reaching out. The errors are as mentioned in my previous message. I have now also included the screenshots.




I look forward to hearing from you soon.


Best regards,





My errors are the same as those that @Cool_Vibe_Tesla noted.








New Member

Me too the same problem of connection on server with iPhone X whit a Condition Air

AntS Moderator

Thanks, guys.


Just to confirm, was the app working previously for you, or did the above error(s) occur straightaway after the first installation?


And @augustido: are you able to provide the model code of your air conditioner; iOS software version your iPhone's on; and Smart Home app version you've got?

 Say "Hello!" to the Community in The Introduce Yourself Thread.


@ AntS


The app was working like a charm (100%) before. I used it every day without any issues. To me it looks like the errors are caused after an IOS update and no i don't consider a downgrade of the IOS version.


Thanks and best regards,


@ all is there any update or progress that can be shared?

AntS Moderator

@cool_vibe_tesla: Thanks! I've fed back what you guys have posted here to our Home Appliance peeps. Me or one of the other moderators will keep you updated on any developments.


In the meantime, if any folks have any further info about their experience with the app (and relevant device model codes, app and software versions), please definitely share it here and we'll add it to the investigation.

 Say "Hello!" to the Community in The Introduce Yourself Thread.


Same problem as everyone else... Trying to connect Smart Home app to my Powerbot 9250 vacum using iphone 7 ios 11.2 and can not connect to server it just keeps asking to retry.

Have tried Connect app as well with no luck either

First Poster

Same here...

I first thought it was a iPhone X issue... But same issue on my 6s+

Then I thought reading this page it might be linked to ios upgrade... Tried with my old 5 and it worked...

So there is an issue with the last version of the smart home app and the last ios... And support seems fairly poor :(

Moreover, every few months (when it was working) the app would require me to restart connection to my heat pump (stating it needs update..)


This is dramatical as the main reason why I got this remote controle is to be able to turn off/on my heat pump when I m away (takes several days to warm up the house) so it is just useless as I can't rely on it...


Which bring me to another question... Is there a way to plug a Nest or Somfy or whatever connected thermostate to samsung heat pumps ?? Just to get reed of this terrible software ...

Top Liked Authors