Support

Open search

Gear s3 won't automatically reconnect to bluetooth when back in range.

Highlighted
SOLVED
First Poster

Hello wonder if you can help.

 

I have just purchased a Gear s3 and I have it paired and connected to my iPhone 6. The watch works perfect until I become out of Bluetooth range and thus my watch will lose connection, which is as expected. The problem comes when I’m back in Bluetooth range i.e. back with my phone the gear s3 will not automatically reconnect like other devices I have left it 30mins plus and it still won’t automatically reconnect. I have to manually keep turning Bluetooth on and off on both the watch and phone and then clicking on both the Bluetooth connections on my phone (Gear S3(DC10) & Gear S3(DC10) LE) to try and get it to reconnect eventually after going through this process multiple times it will finally connect again. Any help will be appreciated as I can’t keep doing this every time I’m away from my phone. Thanks In advance.

154 REPLIES 154
Highlighted

Hi

 

Gear 3:

Samsung Gear: 2.2.17022862

Gear S Plug-in: 2.2.03.17061361

 

Phone:

Samsung S7 SM-G930FD

Android 7

Baseband: G930FXXU1DQE8

Kernel: 3.18.14-11104523 dpi@SWDG9810 #1  Tues May 16 15.12 KST2017

 

Over the air upgrade.

 

Regards

 

Peter

Highlighted

Thank you, I would appreciate an escalation since support is useless... If I could, I would have returned my phone abnd watch. I'm very unhappy with my move from Apple to Samsung.

 

Samsung Gear 2.2.17022862

Gear S Plugin 2.2.03.17061361

 

Updates are OTA, and it says the latest version is already installed of the app.

I'm a Galaxy S8 + on Android 7.0, Samsun Experience 8.1, and Android security patch level July 1, 2017.

Highlighted

Same issue with my Samsung Galaxy S8+ not autoconnecting to my S3 Classic when back in range.  Never had this issue with my S7Edge. 

 

Gear S3 Classic

 

Gear Version 2.217022862

Gear Plugin 2.2.0217042161

 

S8+

Android Version 7.0

Samsung Experience 8.1

 

Kernel

4.4.16-11449429

July 3, 2017

 

Highlighted

Thank you for finally showing interest Samsung. I can't get into Samsung Gear on my phone because there is no device connected to get past the Welcome Screen. In Google Play it will not let me update so I assume I have the latest updated version, likely updated over the air. I have a Z Force with Android 7.0 and a Gear S3 Frontier Tizen 2.3.2.3, both are brand new. I do not want to reset my Gear because I'll lose my S Health data. What else can I provide to help you fix this? Feel free to contact me directly.

Highlighted

Thanks guys. :smileyhappy:

 

I've sent that info over to our software team. I'll keep you all updated.

 

Edit: Also, if you're able, can you use the Samsung Members app to pull and send log files to the software team? Samsung Members > Feedback List > Compose (notepad icon) > Error report > select the relevant area/title > write and send (ensure system log data enabled/ticked). If you can get the title as close to the thread's topic as you can, that'll flag it up at the Samsung end.


 Say "Hello!" to the Community in The Introduce Yourself Thread.


Highlighted
New Member

I solved the problem.
In my case, the problem was with the LG G5 (Android 7.0)
The solution is to clear the cache for the Bluetooth application.

 

  1. Tun off Bluetooth
  2. Then select on the settings
  3. Browse for the Application Manager
  4. Display System apps
  5. Select on Bluetooth
  6. Select to stop it forcefully.
  7. Now clear the cache
  8. Tun on Bluetooth
Highlighted

I have tried that, and that temporarily solves it, but next time I am out of BlueTooth range the same thing happens again, and I do not want to do the whole backup > reconnect > restore cycle each time the watch loses BlueTooth. 

Highlighted
First Poster

I had this problem, probably after connecting a new bluetooth device to my S7. Solution for me and hopefully for others, and which has held for a few days, was to clear the system cache.

Highlighted

Thanks ! This has worked for now. After doing those steps it got reconnected . To check I went out of the range and than came back and bingo!!!! It connected automatically ! I don't know for how long will this work 

Highlighted
Good work ! It worked pretty well for a while
Top Liked Authors