Support

Open search

Gear s3 won't automatically reconnect to bluetooth when back in range.

Highlighted
SOLVED
First Poster

Hello wonder if you can help.

 

I have just purchased a Gear s3 and I have it paired and connected to my iPhone 6. The watch works perfect until I become out of Bluetooth range and thus my watch will lose connection, which is as expected. The problem comes when I’m back in Bluetooth range i.e. back with my phone the gear s3 will not automatically reconnect like other devices I have left it 30mins plus and it still won’t automatically reconnect. I have to manually keep turning Bluetooth on and off on both the watch and phone and then clicking on both the Bluetooth connections on my phone (Gear S3(DC10) & Gear S3(DC10) LE) to try and get it to reconnect eventually after going through this process multiple times it will finally connect again. Any help will be appreciated as I can’t keep doing this every time I’m away from my phone. Thanks In advance.

154 REPLIES 154
Highlighted

Also suffering from the same issue....

 

What do you mean by removing them from battery optimization. The only option I have on my Note8 is Settings->Device Maintenance -> Battery -> (scroll down to the bottom) Unmonitored apps.

I have Galaxy Wearable listed in there so it's running at full power. 

Is there another way to remove an app from battery optimization? Also, what do mean by the Gear S Plugin? I don't have that listen among my installed apps.

 

Thanks!

Highlighted
Found the Gear S plugin among the installed apps, however it can not be added to unmonitored apps.
Highlighted

Hi guys 

 

i had the same problem since i changed the p20 pro fot the mate 20 pro and i found a solution, at least for now , just go to your phone to 

 

This is for huawei using Galaxy watch 

 

1) settings 

2) Apps

3) Apps

scroll don to

4 ) Galaxy wearable

5) power  usage details

6) App Luch

7) turn off manage automatically

8 ) Turn on auto launch, secondary launch and run in backround 

 

problem solved it takes around 1-2 minutes to reconnect, i gues it will be same for samsung phones 

Highlighted

My Gear S3 and Galaxy 9+ also doesnt reconnect if i move away, but this only just happened after a new update.

And i have to reconnect everytime.

I have tried all from a reset to clearing just about everything. And still when i move away

they dont reconnect when close again.

 

Update: this issue fixed itself with the new One UI. Now it reconnect with no problem and all by its self

Highlighted

I am trying your fix greaet- none of the others were successful and what you say makes sense.  Fingers crossed 🤞🏼🤞🏼

Highlighted

Hi

Any news concerning this issue? I run nokia7plus and gears3, same problem, no solution found yet

Jc

Highlighted

In my Nokia 7 plus same problem

Please help

Highlighted

https://eu.community.samsung.com/t5/Objets-Connect%C3%A9s/Samsung-Gear-S3-Nokia-7-plus/m-p/1060150#M...

UnfotunatlyLooks like  we must help ourselves.

If you speak french take a look at the link above. We are trying to find a way out of this issue there.

Otherwise, i'll be back when i got a solution, if ever..

Jc

 

 

Highlighted
It's almost a year after this has been posted and this is _THE_ solution to the problems I've been having and pulling my hair about.
Highlighted
Did it work?
Top Liked Authors