Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy Watch Won't Switch to WIFI Automatically

(Topic created on: 19-12-2018 11:15 AM)
1834 Views
JS_
First Poster
Options

When I move out of bluetooth range of my phone, my Galaxy watch won't switch over to wifi automatically. It will only switch onto Wifi if I go into the connections menu of the galaxy watch.

 

My wifi option are set to Auto but this sometimes changes on it's own to either Always on or Always off.

 

The model number is SM-R800.

 

Anyone know how to solve this issue?

 

3 REPLIES 3
lisafox16
Voyager
Options

I see this all the time. I have it set to auto but turn my GW off at night to wear my S3 (as the sleep tracking isn't working properly at the moment), when I turn it back on it has automatically switched back to always on. This happens every single time - another bug!

Dom797
Apprentice
Options

Same problem here the watch doesn't switch automatically to WiFi when out of range of Bluetooth. 

 

Edit: so it does seem to work but takes really long. My Gear S3 was connecting to WiFi immediately. 

Hope it's gonna be fixed in software update. 

vvv850
Student
Options

Same here. Just bought the watch and set it on Always on wifi but noticed that it disconnects after some time and then refuses to connect to the same SSID. It either says, authentication error, cannot connect to ...., or doesn't say anything.

 

Restarting the watch fixes it temporarily.

 

Keeping it on Auto, does changes from bluetooth to wifi in about 2 minutes (which is completely useless) when it disconnects from bluetooth.

 

Extremely dissappointed.