!-- End Google Optimize -->

Open search

Galaxy Watch Stops Recording work out part way through


So this is really annoying now.  For months the watch has been fine but a couple of weeks ago now I got half way through a run and the watch stopped recording.  I use the watches work out app, select running (basic work out) and press start.  It records for about 10 minutes and then stops.   So a couple of days ago I set the screen to stary on during the run and it was fine for one run.  I ran again today and again it stoped after about 2km; no record of the run at all.  Any help would be greatly appreciated.

177 REPLIES 177

I have auto pause turned off, but this still happened to me. That said, I pause manually and I can't remember if this happened me to after a manual pause or randomly.


As the previous poster said, this seems to be alright during cycling, but running it is absolutely haywire and happened to me both after 1km and after 7km.


I'm presuming this is a relatively easy bug to fix as it wasn't a problem before what seems to be an update issue.


Hey guys,


we can certainly get our developers to have a look at this.


Could you please send our developers and error report with log files from Samsung Members? Find how to do that here: Galaxy Watch/Gear smartwatches - How do you submit an Error Report?

Hi. I would love to be able to do this, however I'm not willing to stop my workout, walk over to my phone, get on the wearables and go through the steps to get reports sent. This doesn't seem like a logical way for us to have to get this issue fixed. I mean the watch was made for working out.

Thanks for the info TessM.


FYI, the instructions for reporting the error do not match the Galaxy Watch interface.


The instructions say to navigate to Settings > About Gear > Report Diagnostics >  Toggle On


As far as I can see, "About Gear" doesn't exist in my Galaxy Watch settings.  However, I found this path:

  Settings > About Watch > Debugging > Turn on


Am I right in thinking that this is what needs to be done?



Yes @sjepaddock ,


that appears to be a similar route. Alternatively,  you can follow these steps: As soon as you experience the issue (or within 15 minutes of it happening), on your phone, launch ‘Galaxy Wearable App’ > More (3 dots) > Contact us > Error Reports > Input Symptoms > SEND. 


Thank you for the infomration. We will ensure the next time it happen to send the data straight away.


I will send an error report next time my watch gets the "whirlies" (see picture on previous post)

First Poster

Exact same issue on Galaxy Watch. Started recently so also assume it's to do with recent update. Records run for about 2km exactly then screen goes black and the workout has stopped.


Really frustrating can we please get this fixed


This has been happening to me aswell. Is there a way of editing runs together?




I tried sending an error log just now as suggested by TessM. Unfortunately, I got an error message (see screenshot). 


Any top tips, TessM, to ensure the error log gets sent? Would the error report that I wrote have been submitted without the log? Is it worth trying to submit again , or should I just wait until next time ? 





Top Liked Authors