Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy Watch 4 Emergency Calls Only Fix - O2 Network

(Topic created on: 15-01-2022 06:03 AM)
Ian_McD
First Poster
Options
Wearables

If you're on O2 and you're getting "Emergency Calls Only" on your watch when out of range of your phone here's the fix!

I know this is a big problem for a lot of people, some of whom have returned their watch because they can't get it to work. I've detailed the process right from the start for the benefit of people who have come straight to this thread and may not have already tried most of the suggestions on other threads, most of which are relevant.

This guide assumes that you have already set up your eSim and have activated the mobile plan in the Galaxy Wearable App in the Mobiles Plans section. Go in the following order:

Settings On Your Phone

1) Settings> Advanced Features> Call And Text On Other Devices - Enable

Settings On Your Watch

1) Settings> Connections> Mobile Networks> Select Auto  (Always On can be selected but Auto works fine and is better for battery life).

Go To The Wearable App On Your Phone

1) Watch Settings> Advanced Features> Remote Connection Turn On - Enable

Now here's the bit where I think it goes wrong for most people not being aware of this next step.

2) Where you just enabled the Remote Connection, stay there but this time tap on the text that says "Remote Connection" rather than selecting the toggle switch.

3) You will now enter a sort of hidden menu that contains a switch called "Calling" and it says "Make and receive calls on your watch without a Bluetooth connection to your phone". This needs to be enabled. It takes a few seconds to activate.

Now to test your connection.

1) Your phone must be on and connected to your phone data plan or wifi.

2) Make sure your Bluetooth is switched on on your phone. Although it is not being used turning it off disables most of the features in the Wearable App including what you need for this to work!

3) You can now turn off the Bluetooth on your watch to simulate being away from your phone (or you could go for a walk and leave your phone at home!). Give it a few seconds while the phone switches over to the network (a little cloud should appear on the watch face), mine takes about fifteen seconds to switch over.

4) Make your call. Hopefully if all is well you should be good to go!

Good luck! I came within a whisker of returning my watch after numerous visits to the O2 Shop and hours of messing about simply because of the hidden setting under the "Remote Connection" settings that I only found by accident!

8 REPLIES 8
antikythera
Black Belt 
Options
Wearables
Excellent first post, very informative!
0 Likes
Members_puaZxGM
First Poster
Options
Wearables

Same problem here. Been to 5 o2 stores with my watch 4. Last o2 was yesterday at Cheshire Oaks. They reset the watch and did a fresh install and an esim swap. I did everything and restarted the watch. Still only emergency calls but I am able to send and receive sms. I checked everything you just posted and its all correct. I don't know what else to do. I went to the samsung store to be told there is a 2 week waiting time to see a samsung technician. 

0 Likes
Leics654
First Poster
Options
Wearables
I had exactly the same problem and was very lucky to, after several well intentioned but failed attempts at help from O2 and Samsung staff, happen across someone on the O2 helpline who knew about the "hidden menu". My only comment would be my experience is that there's no need to have bluetooth on on the phone but it does have to be on on the watch for remote calls to work, even though you're not using it to connect the watch to the phone. Odd. Although the remote calling does work in this way, for some reason after a day or so it always seems to stop again, easily resolved by toggling the "call and text on other devices" toggle on the phone settings off and on again. Annoying though as obviously not something you can do if you've left the phone at home and are relying on the watch. This really needs resolving! Anyone else got a solution to that? But the main frustration is O2 selling 4G versions of this watch but not explaining anywhere how to set it up - even to their own staff!
0 Likes
RJ99
First Poster
Options
Wearables

Losing my mind, I have tried all of the above yet still cant make calls from my watch! So disappointed in this!

0 Likes
H11hdc
First Poster
Options
Wearables
Please can someone help? Remote Connection doesn't let you tap it ????
0 Likes
Rebecca4394
First Poster
Options
Wearables

Hi,

I don't get the cloud appearing over the watch face it just has the picture of a phone with a line through it.

All the others parts in your post are enabled i think... am I missing something to get the cloud to appear?

0 Likes
Members_WWlTDu0
First Poster
Options
Wearables

I'm not sure that there is actually a 'fix' for this as it is not actually an issue. If you read the O2 Watch Airtime T&C's, they do not offer airtime and minutes, only data. Turning the Bluetooth off to test will give a false impression as the call will work fine if connected to the same WiFi. The information from O2 is here: https://www.o2.co.uk/termsandconditions/mobile/samsung-watch-airtime-plan-terms

 

I'm going to speak to O2 to see if they have any different plans but, for the time being, I think calling from the watch without connecting to your phone is not a service offered by O2.

0 Likes
DarkScouser02
Apprentice
Options
Wearables

Hey dude, ive done these steps but still get the prompt on my watch. Do u have any tips. I tried asking O2 online but they didnt help at all 

0 Likes