Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Contactless Payments not working on watch 5 pro

(Topic created on: 27-09-2023 04:04 PM)
3762 Views
geg96
Student
Options
Got a Galaxy Watch 5 Pro in February this year and use Google Pay quite a lot with it.A few days ago (using London Underground) the contactless payment was rejected, so I tried the other card in my google wallet (also on watch) and it also failed. I used google pay on my phone (s23U) and it worked fine.
Has anyone else had this problem? I can't think of any settings I might have changed.
I thought it might be a bug with Google Wallet/Pay whatever it's called, so I tried using Samsung Pay again and that's also not working. The diagnostics Samsung Members app thing says the NFC is working fine.
I have tried the following suggested solutions:
  • Restarting the watch and the connected phone.
  • Ensuring that NFC is turned on, on my watch, and turning it off and back on again.
  • Deleting the cards and re-adding them from the Google Pay and Samsung Pay apps from both my phone and watch.
  • Ensuring the cards themselves are not blocked, and attempting to add different cards (none work).
  • Ensuring Google Pay and Samsung pay work with these cards on another device.
  • Ensuring that the phone, watch, google pay app, Samsung pay app and galaxy wearable app are all up to date.
  • Uninstalling and reinstalling Galaxy wearable.
  • Deleting the cache and data from Galaxy Wearable.
  • Deleting the cache and data from the Google Wallet app and Samsung Pay plugin and app.
  • Deleting the Google Wallet and Samsung Pay apps and reinstalling them (from both the phone and watch)
  • Doing a factory data reset on the watch.
Any other suggestions? Samsung support only suggest I drive to a service centre (a few hours away). When the Google Wallet contactless method fails, a message saying "that didn't work" pops up.
20230927_090313.jpg20230926_152412 (1).jpg
0 Likes
3 REPLIES 3
Obsydian
Samsung Members Star ★
Options
Hi has this just happened once?

I have had the same issue maybe twice over a year only with TFL tubes.
Regards Obsydian - (Car & Tech Evangelist)

MY DEVICES: ZFold4, Watch6 Classic, Book2 Pro i5 5G [Laptop], Buds Pro2, M70A 32 & 43”; [Monitor], Smart Tags, Dell Inspiron G5 [Laptop] / FAMILY DEVICES: ZFlip3, ZFlip4, ZFlip5, Watch6 Classic, S8 Ultra; S7+ [Tablet],  Buds Pro, iPhone 12, iPad Air 2, Air tags, iPad Mini 5, iPad Pro 12.9 GEN2 [Tablets] / HOME DEVICES: QN95A [TV], Q900A / SWA900S [Soundbar, Rears], MC28M6075 and MC32K7055 [Microwave], Jet 75 Complete (Vacuum), Samsung Level [Speaker]
geg96
Student
Options
It happened first with TFL a few days ago, and since then hasn't worked anywhere
0 Likes
geg96
Student
Options

Samsung have offered to collect and repair it, but given that the problem only occurs when trying to make contactless payments, how will the specialists check whether the watch is fixed?
Some element of the NFC still works, but contactless payments, with any bank card, don’t work. When i do the diagnostic check on the Samsung Members app, it says NFC is working fine.
I'm worried if I send it off they won't find a problem and will charge me for it, having read their t&cs:
The warranty on your device covers defects in materials and workmanship, and upon receipt of your device, it will be fully inspected in

accordance with the terms of our warranty.

In the event that a fault on your device is found not to be a manufacturing defect, then the repair may be chargeable; examples of this

may

include evidence of the device not being used in accordance with the instruction manual, or external damage, which may affect the

structural

integrity of the device.

Where such cases occur, you will be provided an estimate to repair the device to the manufacturer's specification, returning it to a

warrantable

condition where appropriate.

Please note that it is not possible for our engineers to complete a partial repair to a specific area of your device if, for example, the

device is

cosmetically damaged. Quotations will be provided for the full cost of the repair of the whole device back to original specification.

 

Do you think I should let them collect and try and repair it?

0 Likes