Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

I can’t connect my Nintendo Switch to Samsung TV.

(Topic created on: 04-04-2020 05:27 PM)
Asylum_Demon
First Poster
Options
TV

It's not problem with HDMI or dock station.IMG_20200404_183831.jpg

 

30 REPLIES 30
Darthfaker
First Poster
Options
TV

I have the same issue with Samsung UN58TU800k, i did the suggestions in the post but it no works for me 

Aussie_IT_Hero
First Poster
Options
TV

Howdy, after a software update my Switch did not connect to my Samsung. Tried everything. Turns out all I needed to do was restart the Switch console and all works fine. 

0 Likes
Kujo2u
First Poster
Options
TV

I am having the same problem. Have tried changing RGB to limited and for a second it recognized the input as a Nintendo Switch but never showed a picture. Now it’s back to not recognizing the switch at all. I tried unplugging and plugging TV back in with no success. Very disappointed with Samsung for having this known problem and not fixing it. 

5amsung-meme
First Poster
Options
TV

I have the exact same issue and still hasn't resolved after trying everything. The Nintendo switch was working last week and it just stopped this week. The only explanation is a bad firmware.

Samsung told me to just wait...

Needless to say, I will not be buying a Samsung tv ever again due to their adware and software that destroys the life quality of their product.

0 Likes
DavidM5
Apprentice
Options
TV

HELP! I have a similar problem and I’ve been looking everywhere for a solution. I have a Samsung (ue55mu7005) .

When i plug the switch into the console, its showing picture first,  but after a little while the tv goes black for a bit and then it shows “no signal”. Sometimes it works for hours, but mostly just 1-10 minutes.

I’ve tried all different hdmi ports on the tv, i reset the switch, i changed the settings in the switch for the RGB Range, from Automatic to Limited, I changed resolution to 720 etc as I’d read worked for some. But still, “no signal”. Also, the first time i plugged it in (yesterday) the tv detected it fine, but now it doesn’t find it, but i can still go to the hdmi “channel” and the switch will show (for a period of time, that is)

What can I do?? The switch is brand new and I gather its not the switch that’s the problem...Please help😩

EDIT: I also tried turning off the Apple TV since I read that could cause it, but it didn’t help.

Aussie_IT_Hero
First Poster
Options
TV

Howdy, I do not think your TV is the problem. The problem is with the Switch. Take it out of the dock, make sure you have downloaded the latest OS for the Switch and then hard restart the Switch. I think it’s the software in the switch for some reason. Once you have restarted the Switch, place it in the dock and you should be good. Let us know how you go. I was just as frustrated at Christmas when this happened to me.

0 Likes
DavidM5
Apprentice
Options
TV

Thanks so much for the tip. So far I only tried the reset where you can keep the game data.

I did have time to try it on a friends tv, same issue. Read your tip and tried the hard reset, first it lost connection, but undocking/docking let us play for a few hours without glitch. Gonna try it home now and see how it goes. Good to hear that its not likely to be the tv since its kinda “new”.

I almost screamed out loud today so I can imagine the feeling of this happening at Christmassy to well 😄

0 Likes
ooktaylor
First Poster
Options
TV
I've tried the options noted above but nothing seems to be working.
I'm connecting it to the one connect box and it recognises a switch has been connected then says it is not getting a signal.
It works fine on my other Samsung that doesn't have a one connect box
Any thoughts or recommendations?
0 Likes
Aussie_IT_Hero
First Poster
Options
TV

Reboot / restart the switch. Give it time and make sure it has latest software updates then try in the dock again

0 Likes
ooktaylor
First Poster
Options
TV
Tried all that. Still no go. All software is up to date on TV and switch. Done a reboot on both
0 Likes