Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

S23 5GHz connectivity Problem

(Topic created on: 12-03-2024 06:02 PM)
1351 Views
azzer2000
Explorer
Options

I recently purchased my S23 direct from Samsung. Upon turning the phone on and transferring from my old Samsung phone i noticed that i was connected to my home WiFi 5Ghz band and it was displaying "connected with no internet" i turned the internet on and off a few times restarted router, forget network re add etc. And it connected up ok.

I did all the updates and proceeded to use the phone, however regularly i still get the "connected with no internet" error and it disconnects, connects to my mobile internet and then re connects. I have now resorted to using the much slower  2GHz band on my router which at the moment appears to not have this issue. Also after researching the problem i have found that many other people have the same issue. I would have returned the phone had i not sold my old phone and already transferred all the data over and gone through the hassle of setting up all my banking apps etc.

So my question is, is everyone else still having the same issue as me? Not the WiFi 6 problem that just requires you to change the MAC to the phones MAC but this 5GHz specifically?

Also how long has this problem being going on, did an update cause it or is it a hardware fault?

And finally have Samsung acknowledged the issue and are they working on a fix for it?

 

Thanks

0 Likes
14 REPLIES 14
azzer2000
Explorer
Options
No I've been steering clear of that due to the inconvenience buy may give it a go if the problem persists
0 Likes
Robin999
Samsung Members Star ★
Options
Back to the "Intelligent wifi" menu. Scroll all the way down the screen and repeatedly tap on where it says "Intelligent wifi". After a few taps the Connectivity labs option will appear. In there you can find some useful tools that might help you.
Lex1970
Pioneer
Options
I did have the same problem which at the time I could not resolve, however for the last month this problem seems to have gone away by itself there must have been a software update for me which resolved this issue
0 Likes
azzer2000
Explorer
Options
Thanks. I reset my WiFi and Bluetooth setting last night and it's not happened since,,, yet. Will see how it goes time will tell.
0 Likes
niraj12
Pioneer
Options

I have the exact same issue on a S23FE model that is brand new. Virgin Media Hub 3. Happens on both wifi bands. Samsung have not acknowledged the issue and the repair store say there is nothing they can do as they don't know what is causing this issue. I showed them various threads on here with people having the exact same issue and they just can't help.

0 Likes