Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy S23 Series

cancel
Showing results for 
Search instead for 
Did you mean: 

Who Me Too'd this topic

azzer2000
Explorer
Options

I recently purchased my S23 direct from Samsung. Upon turning the phone on and transferring from my old Samsung phone i noticed that i was connected to my home WiFi 5Ghz band and it was displaying "connected with no internet" i turned the internet on and off a few times restarted router, forget network re add etc. And it connected up ok.

I did all the updates and proceeded to use the phone, however regularly i still get the "connected with no internet" error and it disconnects, connects to my mobile internet and then re connects. I have now resorted to using the much slower  2GHz band on my router which at the moment appears to not have this issue. Also after researching the problem i have found that many other people have the same issue. I would have returned the phone had i not sold my old phone and already transferred all the data over and gone through the hassle of setting up all my banking apps etc.

So my question is, is everyone else still having the same issue as me? Not the WiFi 6 problem that just requires you to change the MAC to the phones MAC but this 5GHz specifically?

Also how long has this problem being going on, did an update cause it or is it a hardware fault?

And finally have Samsung acknowledged the issue and are they working on a fix for it?

 

Thanks

0 Likes
Who Me Too'd this topic