Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

S22 Wi-fi calling quit working after installing One UI 5 (Android 13)

(Topic created on: 18-11-2022 02:11 AM)
Droiderat
Explorer
Options
Galaxy S22 Series

I have a new Galaxy S22 (SM-S901U1 - USA factory unlocked), purchased and placed into service on October 29 (as an upgrade from an S21).  While using the One UI 4.1 firmware (AVI5), Wi-Fi calling worked flawlessly (both making and receiving calls), as it did on the S21 (One UI 4.0) prior to that.

On November 15, I installed One UI 5 (Android 13); BVK1, and have found that Wi-Fi calling no longer works.  When I try to make a call, I receive an error message "Turn off Airplane Mode to make this call"; and calls made to me don't ring on the phone.

Wi-Fi calling is, of course, enabled at both my carrier (a T-Mobile MVNO) and on my phone.  FYI, the SIM is in SIM2 (eSIM), though I am not sure that is relevant to Wi-Fi calling.

Does anyone know how to fix this or is it a bug in the firmware?  I need Wi-Fi calling.

0 Likes

1 Solution


Accepted Solutions
Solution
Droiderat
Explorer
Options
Galaxy S22 Series

UPDATE:  I determined that the OTA update from Android 12 to Android 13 revoked all of the permissions for the app "Carrier Services" ; once these permissions were restored (followed by a reboot), Wi-Fi calling became fully functional again.

View solution in context

0 Likes
13 REPLIES 13
BandOfBrothers
Samsung Maker ★★
Options
Galaxy S22 Series

Hi @Droiderat 

I've not come across a widespread issue with Android¹³ _ Samsung One Ui 5.0 and Wi-Fi Calling issues.

As this feature is typically Network Driven and Networks have their own flavour of software and csc on their branded Samsung phone's i.e phone's supplied by a network you may need to take this up with your network too.

Even if Samsung supplied the phone it would still be the Network that would need to look at this.

Have a look at any relevant network forums to see if people with the same phone and software are experiencing the same issues.

If I can be of any further help then please don't hesitate. Take care.  😎 

 


Daily Driver > Samsung Galaxy s²² Ultra 256Gb in Phantom Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help.

0 Likes
Droiderat
Explorer
Options
Galaxy S22 Series

Hi @BandOfBrothers,

Thank you for your note.

In theory, a network association must be assessed, but I don't believe that is my issue.  My phone is a factory-unlocked S22; I didn't buy it to use with any particular network (and it doesn't have any network-specific software installed; it does have an eSIM).  The error message "Turn off Airplane Mode to make this call" indicates that the call is being stopped by the phone, and not making it to the network; the Wi-Fi Calling switch is toggled, but the phone doesn't appear to recognize that.  And, finally, all was well with Android 12, and the day I installed Android 13, Wi-Fi calling ceased to be functional.  The updated firmware came directly from the Samsung server.

My sense is that there is a problem with the Samsung BVK1 One UI 5 firmware (but I'm not ruling anything out).

You don't indicate the model number of your Ultra, its firmware, your country of residence, or your network, so I really have no way to assess how your experience might impact my situation.

0 Likes
Bipolarbear4873
Apprentice
Options
Galaxy S22 Series
This is a problem I had. My WiFi dropped so used hot spot and or blootooth and didn't work , 😩
0 Likes
Robot-
Samsung Maker ★
Options
Galaxy S22 Series
I had similar problem with my 21U after update, all the troubleshooting with Vodafone, they couldn't resolve it, error was "no data connection"

That's when I started coming on here to try find solution

In the end I turned off WiFi calling, settled for dodgy signal and later traded my problem away for this bad boy, no issues anymore
0 Likes
Newbs20
Journeyman
Options
Galaxy S22 Series
I also have a similar problem since updating to ONE UI 5. I have a S21 Ultra and had no problems with WiFi until I updated to Android 13. Now the phone loses connection randomly throughout the day. Constantly reporting the issue on the members app but that's been a waist of time
0 Likes
Solution
Droiderat
Explorer
Options
Galaxy S22 Series

UPDATE:  I determined that the OTA update from Android 12 to Android 13 revoked all of the permissions for the app "Carrier Services" ; once these permissions were restored (followed by a reboot), Wi-Fi calling became fully functional again.

0 Likes
Lord_belial
Explorer
Options
Galaxy S22 Series
Same problem here with wifi calling
0 Likes
Robbie1966
First Poster
Options
Galaxy S22 Series
I have same problem but find that if in flight mode with WiFi on, then after a restart WiFi calling works fine. Its only a problem when the phone is in normal GSM mode and then you use WiFi calling (eg bad GSM signal or flight mode plus WiFi) .
It would be nice to have a simple mode that forces WiFi calling when connected to favourite WiFi network so when I leave the house I don't have to remember to switch off flight mode.
Definitely a bug that needs fixing
0 Likes
Robbie1966
First Poster
Options
Galaxy S22 Series
PS. WiFi calling was OK prior to latest Android 13 update 😞
0 Likes