What are you looking for?

Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

USB-C Port not Working on Samsung Galaxy Book S after Windows 11 Upgrade

(Topic created on: 12-02-2024 08:53 PM)

I upgraded my Galaxy Book S to Windows 11 in early January and right after the upgrade, the left USB-C port stopped working: it doesn't charge or detect connected devices anymore.

Given it the problem occurred just after the installation of Windows 11 and that I am sure it was working just fine, before the upgrade, I'd rule out a hardware problem.

I tried updating the USB port drivers, disabling the USB port drivers, as well as uninstalling the USB port drivers in Device Manager and restarting but the problem continued.

I ran Windows update and all updates are installed.

I also tried running Samsung update but it doesn't seem to be compatible with the Galaxy Book S.

I don't want to roll back to Windows 10 to resolve the issue as Windows 11 works much better.

Did anybody experience a similar issue? If you did, how did you resolve it?

Thanks in advance for any replies.


Galaxy S10 | Galaxy S10e | Galaxy Tab S5e | Galaxy Book Pro 15 i7 | Galaxy Book Pro 13 i5 | Galaxy Book S 13 8cx |

I spent an entire day with Samsung Support without success and they advised to contact the approved local repair center. I decided against it as I had had a rather negative experience when said repair center fried my laptop while performing a simple repair and then attempted to charge me to replace the motherboard (they had fried). Besides, I was sure it was a software Windows 11 issue so there was no point trying to go to a business that makes a profit replacing parts.

I spent a few more hours doing system resets and attempting several troubleshooting procedures. Eventually, I attempted the steps described in the video below, it fixed the issue completely:

How to Fix USB Ports Not Working in Windows 11 (

I hope this info can be helpful to anybody having the same problem.


It looks like while performing the system resets, I lost the Qualcomm power plan which was great Now I am stuck with just the Balanced power plan... it should be pretty easy to fix though.

Galaxy S10 | Galaxy S10e | Galaxy Tab S5e | Galaxy Book Pro 15 i7 | Galaxy Book Pro 13 i5 | Galaxy Book S 13 8cx |