Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

T7 SSD disconnecting randomly on Windows but not Ubuntu

(Topic created on: 14-04-2024 02:21 PM)
221 Views
aminya
Apprentice
Options

I have a problem with my T7 when it is connected to the USB3 hub of my laptops on Windows 11. This prevents me to use the drive on Windows altogether as the data transfer breaks all the time resulting in crashes in the programs.  This doesn't seem to have the same issue when I use it on Linux (with a btrfs partition).

I have tried all sorts of things, but none of them have worked including:

- Updating the firmware using Samsung Magician 

- Turning off automatic power saving from device manager for the USB hubs

- Turning off selective USB power saving from the power settings in the control panel

- Turning off security from Samsung Magician 

- Repartitioning and trying NFTS or ExFat

- Trying new cables

- Tips in this article: https://www.partitionwizard.com/partitionmanager/io-operation-logical-block-address-disk-was-retired...

 

 

 

I have found these errors in the events of the system:

```

The IO operation at logical block address 0xb1d02e90 for Disk 2 (PDO name: \Device\00000114) was retried.

```

Also 

```

Disk 2 has been surprise removed.

```

7 REPLIES 7
aminya
Apprentice
Options

Any suggestions or solutions? How can I reach out to Samsung customer service? 

AntS
Moderator
Moderator
Options

Hi @aminya , That issue is a little beyond my experience and knowledge. And with none of the stuff you've tried working, it might be best to speak to Support for SSDs.

 

Which country are you based in?

 

In the UK & Ireland the Support team contact info for SSDs would be samsungmemory@hanaro.eu (email) and 00800-8010-8011 (phone).

dsttemp111
First Poster
Options

Hello, did you find a solution? I am having the exact same problem. Havent tested on ubuntu though.

saawood13
Journeyman
Options

I also have this issue and have tried all of the above things. I have used the magician software to update the firmware but it keeps occuring

0 Likes
saawood13
Journeyman
Options

also i reached out to customer service and all they could offer me was their warranty service 

0 Likes
aminya
Apprentice
Options

I didn't find a solution for this. As mentioned, Samsung offered a refund, but I decided to keep it and use it only on Ubuntu, which has been fine. I bought another SSD from another brand for Windows. 

The fact that it works on Ubuntu without issues, shows that there is a bug in the firmware or drivers for Windows.

saawood13
Journeyman
Options

Hey I just wanted to pop on here to tell you I uninstalled the USB drivers and reinstalled them and my drive seems to be working normally on all my ports now! Thought I would post here for future googlers trying to solve this problem. Thank you for your suggestion that it was a windows issue, I would have never though to try this!

0 Likes