Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung G8 after sleep fails to find displayport

(Topic created on: 14-10-2023 10:02 PM)
1583 Views
ebilcake
Explorer
Options

Is there a fix for this? Seems kinda stupid having to force power off and restart the PC to get the monitor to see the PC again.

Turned off the option to turn off the monitor for now in power settings, but it's OLED so ideally I want it to turn off after  15 minutes of no activity. 

73 REPLIES 73
SuperDenton
Journeyman
Options

@PetrasV  This solution you proposed doesn't work for me at all. Other solutions proposed here doesn't work as well. So, for me this is a very big problem. I have to unplug and plug the monitor at least 10-15 times a day because of this issue. And I can't use HDMI. because one HDMI connector I have on my 4090 is connected to my LG C2 OLED TV. So i have to use display port for this monitor. And I also tried 3 different miniDP to DP cables including one that came with the monitor, it is not a cable issue. It is this monitor issue. It is beyond me how such an expensive monitor comes with this much software issues and than they don't get fixed for years.

0 Likes
Jon Doe22
First Poster
Options

I use 43" Samsung G70NC with Nvidia 4090 connected via HDMI port. I have the same issue. There are two ways how to resume the monitor with picture I found that work without the need of reboot:
- unplug and plug the HDMI cable
- reset the display driver using the Shift+CTRL+Win+B shortcut.

The interesting thing is that I can resume the monitor from sleep normally for couple of minutes after it gets to sleep. If it the sleep takes longer, the described issue appears.

P.S.: The very same issue happens to my old DELL monitor connected viac DP->DVI cable. Both monitors are "lost" and "found" together. So it might be also an issue of graphics card or drivers.

0 Likes
Johnny_Dollar
First Poster
Options

Only after a fresh clean install of Win 11 would mine work as it should. Go figure.

0 Likes
villeee100
Apprentice
Options

My monitor just updated its firmware to 1602. Beware this update, now I have to turn on the monitor manually with remote every time I use either my PC or laptop...

 

0 Likes
Ricky9211
First Poster
Options

follow this , it seems fixed the issue
go to nvidia control panel > display > adjust desktop size and position > perform scaling on > gpu

0 Likes
Humoud
First Poster
Options

I fixed it by disable gaming mode

0 Likes
Pts
Journeyman
Options

Just commenting so Samsung would fix this joke of a bug.

PetrasV
Apprentice
Options

For me its fully functional now with latest update. Using DP with included cable and display wakes up when PC is turneed on, after sleep. Finally feels like a normal monitor. 

0 Likes
Humoud
First Poster
Options

Fixed by manually update latest update (downloaded on Samsung website) and using original DP cable.

Also if you have some flicker while using chrome, then disable Chrome "Use hardware acceleration when available"

Now I have 0 bugs.

0 Likes
tech_guru
First Poster
Options

Sleep issue is still a problem for me:

  • Mac Studio M1 Ultra ( Sonoma 14.2.1 )
  • Odyssey G9 Neo ( LS49AG95 with firmware M-A9549GGPA-1015.0 )
  • USB-C/Thunderbolt to Displayport cable that works flawlessly except for the sleep issue. 
0 Likes