Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Magician 7.3.0 wont start

(Topic created on: 27-03-2023 03:47 PM)
24722 Views
W9387_
First Poster
Options

Updated to 7.3.0

It won't open. I have the following in the logs:

"_WINDOW process died, reason::launch-failed"

When running from command prompt, the following error appears after some time:

"[5808:0327/102752.512:ERROR:gpu_init.cc(521)] Passthrough is not supported, GL is disabled, ANGLE is"

40 REPLIES 40
T S
Apprentice
Options

SamsungMagician.exe and SamsungMagicianSVC.exe

0 Likes
Arctic_Hare
Explorer
Options

You can stop SamsungMagicianSVC from running by disabling it from Services in MSConfig. I believe the corresponding registry key is: Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SamsungMagicianSVC

0 Likes
T S
Apprentice
Options

I can do that from Services.msc too. It's not this process that I need to kill in order for the shortcut to work; it's the SamsungMagician.exe process. There are 3 of those processes running. One appears to be bound to serving functions that interact with the GPU and the other seems to be fulfilling network connections. I say this because if I kill either of these off after running SamsungMagician.exe from a command prompt, I get log messages which make those references obvious. These 2 processes also appear to automatically restart as long as the parent SamsungMagician.exe process is running, so it takes a bit of trial and error on each boot up to kill the right process.

The SamsungMagicianSVC.exe process stays running after I kill off SamsungMagician.exe and restart it from the shortcut with the -no-sandbox flag, so I'm not sure what role it plays and have disabled it now but have yet to reboot. Will post back again once I do.

0 Likes
Arctic_Hare
Explorer
Options

OK - Yes, I am experiencing the same behaviour as you. The SVC service doesn't seem to play a role. Is this the Registry that starts Magician in the Notify Icon Area?

Computer\HKEY_USERS\****\Control Panel\NotifyIconSettings\13682860483443418100

Executable Path: {7C5A40EF-A0FB-4BFC-874A-C0F2E0B9FA8E}\Samsung\Samsung Magician\SamsungMagician.exe

0 Likes
tehtechie
Student
Options

It's a Task Scheduler entry that starts it for any user at logon.  Simply disable or delete the Task Scheduler entry. 
tehtechie_0-1684680493434.png

 

0 Likes
T S
Apprentice
Options

Awesome find, thanks! I completely forgot about the Task Scheduler method! I edited that entry, Double click it, in the Actions tab, click Edit, add -no-sandbox to the arguments and then click OK and OK again. Then reboot and Samsung Magician comes up without issues. I have it set to auto hide, so I left the /AUTOHIDE flag in place, and it properly auto-hides, then comes up when I double click it in the system tray.

NinoAR
Student
Options

OMG! It works !

I've been looking for a way to put the -no-sandbox argument at startup but couldn't find where.  Had to load the Magician manually every restart. This finally put a nice end to a long frustrating saga. Thanks!

Arctic_Hare
Explorer
Options

I also added the -no-sandbox to the arguments box in the task scheduler, rebooted, and Magician started. OMG!

JackProPC
First Poster
Options

If you go to Task Scheduler under the SamsungMagician task, open properties, navigate to actions and add the -no-sandbox argument to the details section of "Start a Program", you should be able to have it display at startup as well.
(edit: just noticed that it was already said but I can't delete the post for whatever reason)

0 Likes
ZippyDan
First Poster
Options

This is exactly right.  The Install Wizard has a default option to Run at Startup which is hidden on the very last window of the wizard process behind a Settings button at the bottom left (which only has that one setting). 

Unless you unchecked that setting before finishing the install, that means that even if the Samsung Magician window does not appear on your Taskbar, the Samsung Magician is still running "in the background". 

If it is still running, you can see it "hiding" in the System Tray (the place by the clock and date at the bottom right corner of your screen, where you might need to click a little upwards arrow to see everything that is running.)

For the more technically inclined, this means that Samsung Magician installs itself not just as an app, but as a system service (in Windows, a service is a program that can run before any users login and generally can run for all users  regardless of whether they manually choose to launch the app - so a system service can be thought of as more of a system-level app rather than a per-user-session app).

As long as that service is still running, launching the Samsung Magician app with the -no-sandbox switch won't have any effect.  You need to stop the service first, and then with the service stopped launch the user app with the -no-sandbox switch.

To stop the service, you can choose from the following options:

  1. Right-click on the Samsung Magician icon in the taskbar and choose Exit (but I couldn't get it to actually exit using this method).  You can also select the option to Remove from Startup here - which should disable the service from starting automatically at bootup - and then restart your computer.
  2. Open Task Manager (Start -> Task Manager or taskman.exe) and then choose End Task for the Background Process named SamsungMagicianSVC (32 bit).
  3. Open the Microsoft Management Console Services (Start -> services.msc), and then scroll down until you find Samsung MagicianSVC in the alphabetical list, and finally choose the option to Stop the service.  Here is another place that you can authoritatively prevent the service from starting automatically with the system by changing the Startup Type (right-click -> Properties) from Automatic to Manual (or even Disabled).

After stopping the service via one of these methods, the Samsung Magician icon should disappear from the System Tray (there may be a slight delay so be patient), and only then should you try to launch the app with the -no-sandbox switch.

0 Likes