Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

FIX solution for Samsung Magician won't start / fails to open 7.1 7.2 7.3 8.0

(Topic created on: 06-12-2023 04:38 AM)
3868 Views
0x6A7232
Apprentice
Options

Thanks to @Neil23, I've got the solution down (I think!😞

Force-quitting Samsung Magician, even including the service, did not work for me until I added the argument -no-sandbox in the Task Scheduler (just add it after the /AUTOHIDE option that's already there). 

 

1) Hit Start,

2) Search Task Scheduler, open it,

3) Scroll down the list to Samsung Magician, double-click it to open,

4) Click the Actions tab at the top,

5) Then double-click on Start a program

6) Now, in the lower-right, click in the box Add arguments (optional), and after /AUTOHIDE put a space and then -no-sandbox

7) Then click OK,

😎 Then click OK on the next box. 

9) Restart your computer.

 

Looks like there is another potential issue involving the PATH environment variable being missing, here's the fix if that is the issue, thx @aurum79 :

Change your windows system PATH variable to include the new Samsung Director (C:\Program Files (x86)\Samsung\Samsung Magician). This is done by right clicking on the Start Button, Selecting System from the context menu, choosing Advanced System Settings, going to the Advanced tab, clicking Environment Variables, Clicking on the variable called "Path", then "Edit", selecting "New" and adding the path above

1 REPLY 1
aurum79
Journeyman
Options

I have latest Samsung Magician 8 working on Windows 11.   Here is what I did:  Install Samsung Magician.   Turn off autostart option after installation has completed (Options button).   Delete the link to the app the install placed on the desktop.  Change your windows system PATH variable to include the new Samsung Director (C:\Program Files (x86)\Samsung\Samsung Magician).   This is done by right clicking on the Start Button, Selecting System from the context menu, choosing Advanced System Settings, going to the Advanced tab, clicking Environment Variables, Clicking on the variable called "Path", then "Edit", selecting "New" and adding the path above.  Then add a link to the SamsungMagician.exe app in this folder to your desktop.  The problem is stupid -- Samsung Magician can't find its own directory.   REBOOT.   Magician SHOULD NOT AUTOSTART.   Then start Magician with the link you created every time you boot (or set this link to autostart if you know how).  Works every time!