Open search

Anynet/HDMI-CEC and ARC not working

Hi there,

I have this problem for over a month now.

I have a Samsung TV model UE49MU8005 connected to a Pioneer Receiver model VSX-LX302. Everyhting is well connected, as far as i know, TV firmware is 1210.8.

Tv is connected through a recent HDMI cable (UHD, ARC, etc etc) from the ARC output of the receiver to the ARC input of the TV (HDMI 4). Anynet is on.

When I disconnect the cable and connect it again, it starts identifying the source on the TV and it always says "unknown source" so i have to manually configure the tv remote. After it detects my Receiver, turns it on and off ok, and finishes the connection. Everything seems ok. But the problem starts here:

- The sound does not come out through HDMI from the TV if I select an app from the hub. Neither it does if it's connected to the antenna of the tv.

- I have sound from the cable box and from a PC both connected to the receiver.

- The receiver has CEC on but it the sound is not there. When I disconnect the CEC on the receiver and connect it again, it starts searching for CEC devices but the answer is "no CEC device"! Although the TV is connected of course..

- Anynet stops working too, it doesn't control my receiver when this is happening.

- This bug goes on and off. It works sometimes, other times it doesn't. It seems that theres is some problem in the TV that disconnects automatically HDMI CEC, and then it just doesn't come back.

- I changed cables, update firmwares, disconnected everything and waited, then connected again, called Samsung support and they just don't seem to know what I'm talking about... The problem always persist.

Frankly, I'm considering returning the TV. It's new and for the price it should NEVER cause such hassle.

This is about something that should work perfectly and is not doing so. And it seems that everyone at Samsung knows the problem exists, they just don't know how to solve it... (according to the countless discussions about this topic, at least at the US community..).

Please help!


281 REPLIES 281

Was working great, but wife and kids can't / won't remember.  It is a huge pain as my plug is also right behind mounted tv


Was working great, but wife and kids can't / won't remember.  It is a huge pain as my plug is also right behind mounted tv.


Lol, truth. 


Looking at a WiFi controlled plug with on/off timer.

How about a switch in the electrical board? :winking-face:

Smart, hopefully doesn’t bulk up the outlet area for your mounted location though. For my purposes the WiFi outlet may actually work perfectly because the tv wall outlet is  recessed. I should have gone with the pull out mount instead of just the tilting and it wouldn’t have big a problem. 


Hey guys,


I took delivery of a 75"  2018 q8fn qled TV yesterday and installed the latest firmware available on the USA site. I'm also having issues with not receiving sound via the hdmi arc connection eventhough the soundbar is detected. My tv is connected to a Nakamichi shockwafe Ultra 9.2 soundbar. The TV was an exchange from a 75" mu9000, which worked great with the same soundbar.


I spoke to Samsung support last night and was told that Samsung engineers are aware of the issue and are looking into the issue but are not ready to discuss a solution . They recommend that I connect my soundbar via Bluetooth or optical which both worked fine at reduced sound quality. It's pretty disappointing that one of their top tvs can't have a working arc port out of the box . This is pitiful  and I hope they get their act together. I'm losing faith in this brand. Good luck everyone. I hope they provide a fix soon  


I started having this issue with my Denon AVRX2300W couple days ago. Denon stopped reacting to up/down buttons while doing left/right fine. I tried to reconfigure, but it never succeeds a power down test and stopped working completely. I tried to select Denon, exact model, Marantz (since they are the same company now) and a few others to at least make TV power down the receiver.


It does look like some automatic firmware update broke it.


So... First and last time I will ever buy a Samsung-product.


I bought my QE55Q7FNA 25th of December and to start with , I had not less than 5 questions that I needed help with concerning SMB-connection, flickering picture when playing UHD, not recognizing some .srt-files, ambient-mode (tv had old firmware, worked after updating) and regular networking. I had to talk to first one girl that hadnt the slightest clue about .. anything.. Ok, so I had to talk to a guy at Samsung and his answer was: "I cant answer these questions cause we havent enough knowledge". They then told me that they had written down everything along with my phonenumber and they should get back to me.. Thats .. many days ago and I dont have any hope that they every will get back to me..


NOW.. To this ARC-problem.

I had until last week a Onkyo TX-NR515 reciever where the ARC seemed to work. BUT, I didnt use it for long sin my reciever wasnt able to handle ATMOS. I now have another Onkyo: HT-RC660 and the ARC is totally messed up from the TVs side. I have even videorecorded the audio-settings on the TV where you can see that the TV loses the HDMI-connection every 2-3 second and get it back in also 2-3 second, over and over and over again. I have tried both HDMI2.0 and HDMI2.0a cables and its the same problem. So.. The cable isnt the issue here.


What I have noticed with Samsungs "SMART"-TVs is that they in fact isnt smart at all. The are so far from finshed so their support-people havent even tried all functions. Im very annoyed in both the lack of support but also the lack of compability cause I believe, as somebody else here wrote, that their products isnt compatible at all unless you have a non-existing Samsung-reciver... So...


I really can handle to live without ARC BUT ... Since I have a harddrive with UHD-movies connected to the TV I wont be able to play some AT ALL since they have ATMOS-sound and you cant get ATMOS unless its throw HDMI2.0. No optical cable will work. Will see if I somehow can use 2 HDMI-cables between the TV and the reciever but its pretty pathetic when you have bought a TV for around 1000 EURO when there are so much cheaper TVs with the same specific (without QLED ofcourse).




Well how discouraging to find this post.  New UN75UN8000 TV and Pioneer Elite VSX-LX103 receiver purchased last weekend.  Got everything set up and working without a hitch this week.  Suddenly on second day of using , I tried to stream a movie and got no sound.  Pulling my hair out for an hour last night but couldn't figure it out.  Tried to set up receiver again and it would just hang on the ARC step.  I assumed it was the receiver.  This morning doing some more research I found this post.  After all of the effort to install and wall mount a 75" TV I am beyond disappointed to find out it may have a fatal flaw.  Sigh...


So, I reconnected HDMI and unplugged TV for a couple minutes as mentioned earlier.  Went back into the receiver setup and viola, ARC completed in a flash and everything worked again.  I also checked firmware and found an update available for the TV (already completed in receiver setup) so I also did that.  Given the reports above of this unplug/reset working but only for 10 minutes to a day or two, I'm not overly optimistic.  It's shocking a major manufacturer like Samsung seems both aware and also unwilling/unable to fix this issue.  It is completely unacceptable.  I'm really hoping to not need to exchange the TV but it sounds like that may be the only real fix.  Pretty pathetic...  

Top Liked Authors