Open search

Anynet/HDMI-CEC and ARC not working

Hi there,

I have this problem for over a month now.

I have a Samsung TV model UE49MU8005 connected to a Pioneer Receiver model VSX-LX302. Everyhting is well connected, as far as i know, TV firmware is 1210.8.

Tv is connected through a recent HDMI cable (UHD, ARC, etc etc) from the ARC output of the receiver to the ARC input of the TV (HDMI 4). Anynet is on.

When I disconnect the cable and connect it again, it starts identifying the source on the TV and it always says "unknown source" so i have to manually configure the tv remote. After it detects my Receiver, turns it on and off ok, and finishes the connection. Everything seems ok. But the problem starts here:

- The sound does not come out through HDMI from the TV if I select an app from the hub. Neither it does if it's connected to the antenna of the tv.

- I have sound from the cable box and from a PC both connected to the receiver.

- The receiver has CEC on but it the sound is not there. When I disconnect the CEC on the receiver and connect it again, it starts searching for CEC devices but the answer is "no CEC device"! Although the TV is connected of course..

- Anynet stops working too, it doesn't control my receiver when this is happening.

- This bug goes on and off. It works sometimes, other times it doesn't. It seems that theres is some problem in the TV that disconnects automatically HDMI CEC, and then it just doesn't come back.

- I changed cables, update firmwares, disconnected everything and waited, then connected again, called Samsung support and they just don't seem to know what I'm talking about... The problem always persist.

Frankly, I'm considering returning the TV. It's new and for the price it should NEVER cause such hassle.

This is about something that should work perfectly and is not doing so. And it seems that everyone at Samsung knows the problem exists, they just don't know how to solve it... (according to the countless discussions about this topic, at least at the US community..).

Please help!


284 REPLIES 284

Hi NotHappyHere,

If you are using an AVR, I would really consider the Caavo solution I have posted. If you are using a Soundbar, I think the only good solution is to use a Samsung Soundbar. I am quite sure the the Samsung TV and Soundbar work well together.


Gotta love Amazon Prime, Sunday delivery of the optical cable means a swift resolution (albeit a compromise)!


Optical out from TV to receiver for Dolby Digital 5.1, Xbox One X out to receiver for up to Dolby Atmos with 4K pass-through to the TV. Two remotes and a more complex setup than previously, but it works.

Pretty disappointing that Samsung inherently have a major issue with 2018 model (possibly not limited to) TVs and haven't bothered to respond or resolve it appropriately. Won't be buying another Samsung TV going forward, particularly since the issue is present on top-end QLED TVs costing more than a few thousand.


My case:
I have Samsung UE65MU7002, Samsung bd h6500, Onkyo TX-RZ830, nvidia shield TV, PS3, VU+ solo 4K.
Everything connected to Onkyo with HDMI 2.1 cables - used as a central unit for home cinema 5.1.4 (optical connection is not for me)
Anynet is getting off randomly every 2-3 days. I call Samsung support for 3 times - they sent to me service guy. He tryed many "experiments", but without succes.
I know that man personally, and he told me off the record, how Samsung solves problems - if they can't easily solve it, they will accept the incompatibilityas a cause and turn it off in the firmware without the customer's knowledge (even Samsung devices - TV and soundbar).
For the year and half what I have this TV, no new firmware with the solution. How I read this topic a lot of us have the same problem with different types TV.
SAMSUNG's official response (thru e-mail) was - device incompatibility. You want home cinema? Onkyo is incompatible with our TV! You cant control Samsung AC with your phone? You dont have Samsung phone! You have Samsung soundbar? Oughhh, it is older model, sorry!... atc
For me this was my last SAMSUNG device in my life.
They give promises in the catalog and problems in real usage.

Home appliances:
3pcs AR9..., UE65MU7002, BD-H6500, UE46F6510, Galaxy A50.....
(Onkyo TX-RZ830, TX-NR-709 and 701, NVIDIA Shield, VU+ SOLO 4K, PS3...)

Nevermind, quit working as fast as it started working  :grinning-face-with-one-large-and-one-small-eye:


Hi Wibb...


I was going to reply....give it some time, it will stop working. But you beat me to it. 


We all for sure know what HDMI inlet to plug into on the TV. Mine has worked flawlessly for up to 3 days with the same AVR you use. However, it always fails eventually. 


Best of Luck


Yes.  Worked now won't recognize it at all.  Detects and then says unknown.  One minute i'm watching roadhouse in surround sound, the next I'm back to TV speakers  :face-with-tears-of-joy:


Working!!!  About 3 or 4 Weeks ago, I installed a Wifi plug to make it easier to reset my TV and receiver when the  CEC/ARC stops working.  That was the last time I needed to do a reset!  For whatever reason, (maybe a silent software update?), my CEC/ARC has been working flawlessly ever since.  I have not made any other changes.  I am just so happy that my new QLED TV is working perfectly now.  I would suggest that if you don't already have it set ...  Make sure you have the auto updates setting turned on.  Check for updates and do an update if you have not done so when you first got your TV or if you have not had the auto-update turned on.  So far so good... !    Anyone else find that this problem has been fixed?


I always watch Roadhouse with the sound off anyway. :winking-face:

I did an update to my set when I first got it, and *I think* I turned on auto updates, but I guess I could go back and check. I wonder if Samsung pushes out updates to multiple models at the same time or does them as they become available for specific models....


Same here, I have 75" Q9, when I turn on my TV it doesn't automatically turn on my home theatre, I always have to do it manually. I am sure this problem is from Samsung because I started experiencing this issue when I moved from my Sony to Samsung. I am sure I have everything set up correctly but just won't work automatically. 

Top Liked Authors