Support

Open search

New Gear S3 Frontier stuck on "Finishing pairing" screen

Apprentice

Hi,

I have just recieved my new Samsung Gear S3 Frontier but I am stuck at the "Finishing pairing" screen and can't finish the setup. I have tried restarting both my phone (Nokia 7.1 with Pie) and the watch. Clearing catche and data for every samsung app that i have installed. Removed the watch several times from the bluetooth list in my phone and everything that i found on the internet or I think of. Then I saw a post in Reddit as well with few other persons having the same problem as well right now which makes me thing it is somekind of server side issue. Please if someone from the support see this fix it asap as I want to enjoy my new watch and not looking at a paperweight that I have at the moment. 

6 REPLIES 6
AndrewL Moderator
Moderator
@Boris_Mitov: Are you using the Galaxy Wearables app to establish the connection, as this is required to pair your Gear S3 Frontier to your phone. If not then please visit the app store on your device, search for Galaxy Wearables by Samsung Electronics and once installed, hit 'Start the Journey' > Select the Gear S3 from the list of options and follow the on-screen prompts.
Apprentice

Yes I have installed all the nessary apps for the watch to work. Galaxy Wearable, Gear S Plugin, Samsung Accessory Service and even Samsung Health app. All permisions granted on all of them. And yes I am using the Galaxy Wearable app to make the pair(i first remove the watch from the bluetooth list in my phone so it is clean pair i guess).

Apprentice

I finally managed to pair my watch by going in the Bluetooth settings while the pairing process was in Finishing pairing stage, then I selected the Gear S3 device in the list and manually connected the watch by pressing the Connect button (because it was saying it is disconnected). After that they pair went all the way to the end. I am not sure if that was actually the solution but it worked in that right moment Probably I just got lucky. 

But still samsung needs to fix this. It was very annoying to not be able to enjoy your brand nwlew device.

New Member

I have this issue too with a new Nokia 5.1; it’s very frustrating as the watch was working fine with my old Galaxy S4. 

Apprentice

I had the same issue with my Nokia 8.

 

Expect more of these bluetooth connection problems. It's terrible. When the watch is out of range of bluetooth, and when it comes back into range, it won't reconnect (you have to do it manually). Also, the music player app is not able to connect to phone.

 

It's been reported several times.

Apprentice
Yes, I have that too. I also noticed the problem is reported several times by other users with Nokia phones, even for some users with other brands. I also post this in Nokia forums. For me it is strange that Android One devices have this problem.
Top Liked Authors