Support

Open search

Galaxy Watch Swimming tracker not working

Highlighted
First Poster

Hi 

I am using 42mm galaxy watch. Previously swimming tracker seems to work correctly like length strokes and laps but now its not working. It stopped tracking activity and i dont know why, when i start swimming tracker it start waterlock mode but not tracking any activity.

54 REPLIES 54
Highlighted

I've noticed that there was another update but I since changed to swim.com like the majority of posts on here. Had anyone tried out the watch with the new update?  One of the new features is tracking a swim automatically after 10 minutes.

 

I done 50 lengths today and swim.com tracked it to within 25m, very accurate. I then turned off all the connections and completed 50m with Samsung fitness and it tracked the 2 lengths. Maybe it has finally been fixed ?

Highlighted

I got the One UI 1.5 update on Thursday and tried the Samsung App for my final 20 lengths on Friday.

Counted all 20 without problem but I think I prefer the Swim.Com app.

 

Might give the Samsung app another try next time just out of curiosity to see if Samsung have finally sorted out the problem we've all been having.

Highlighted

Done 50 lengths today and it counted 52, maybe as I have the alert on every 50m. I think it has finally been fixed. I like the swim.com app but I like the idea of a slight pause as I'm building on stamina. Also like it being linked to the other exercises. I'll be using Samsung app again and won't be quick to push the next update. 

Highlighted

I'm up for trying the app again. I swim tomorrow and will report back.

Highlighted

Hi,

 

Has Samsung removed swim tracking from the Gear S3 software?   I believe it used to have it, but I could not find it today.  I followed the menu instructions above as well and it is not on my watch.

 

Did Samsung remove it?

 

 

JSB.

Top Liked Authors