Open search

Galaxy Watch Stops Recording work out part way through


So this is really annoying now.  For months the watch has been fine but a couple of weeks ago now I got half way through a run and the watch stopped recording.  I use the watches work out app, select running (basic work out) and press start.  It records for about 10 minutes and then stops.   So a couple of days ago I set the screen to stary on during the run and it was fine for one run.  I ran again today and again it stoped after about 2km; no record of the run at all.  Any help would be greatly appreciated.

173 REPLIES 173

Started experiencing the same issue in the last month or so. Is clearly a bug that needs to be fixed

Should be an interesting test & result. I too have experienced exactly what you have so a post test update would great please? (I have switched to Samsung Health on my phone to track runs & cycling)

I've never used auto defect and still have this issue more times than not.


@NeilB23 wrote:
Should be an interesting test & result. I too have experienced exactly what you have so a post test update would great please? (I have switched to Samsung Health on my phone to track runs & cycling)

So, test was completed. These are the exact steps I took.


  • Turned OFF all toggles under 'Activities to auto-detect' in the Samsung Health Watch App. These were previously disabled by me when I got the watch last year, but sometime between then and now it seems to have reset. I left 'Alerts' and 'Record location' toggled ON.
  • I was unable to turn off the auto-detect workout option in the Samsung Health Phone App even after re-syncing my watch to my phone  - it was disabled:You can see how the toggle is greyed out hereYou can see how the toggle is greyed out here

I will come back to this...



  • Opened the Samsung Health Watch App -> Record Your Workout -> Workout Out -> Running: 10.00 km. (This is a custom workout that I added months ago and had always previously worked for me. Location and High Location Accuracy toggled ON. Autopause toggled OFF. Guide every 1km. Screen always on OFF).
  • Before tapping to start the Running: 10km, I waited for the GPS icon and the HR icon to stop flashing. GPS locked, HR number displayed. I waited another few seconds, then tapped to start workout.


So far, so good. 1km went by... all good! 2km went by... omg is it fixed?! 3km... wait, where's my 3km buzz? I looked at my watch - the workout screen with my pace, cadence etc had disappeared. I was back on my watch face with the little icon of the running man in the bottom of the screen. Test failed.

Throughout the rest of the run he was there on the screen. I didn't tap on it this time as I didn't want to freeze my watch up. I completed my run, thankfully Strava on my phone had tracked it accurately, minus HR and cadence.


I synced my watch to my phone - apparently the workout stopped tracking at 2.43km. At some point the running man icon mysteriously vanished from my watch screen.


In conclusion, it clearly isn't an auto-detect issue from the watch's side - everything was disabled. It's not a GPS/HR lock issue because I waited for that.

What about if it's a phone issue? Have any of you run without the watch connected to a phone and experienced this?
My new theory is that it works until the phone auto-detects a workout (which we seem unable to toggle OFF - @TessM ?) and then the phone tries to sync it's auto-detected workout to the watch, which ultimately results in Samsung Health on the watch crashing as it's already got a workout in progress... Just another theory.


Anyone experiencing this issue whilst cycling? Tomorrow is my rest day for running so I won't be doing another running test tomorrow, but perhaps cycling.


I don't have auto detect enabled on my phone. Turned it off long before I ever got the watch. My last two workouts have recorded successfully but at this stage it's just hit and miss because I haven't changed any settings!


Thank you for your thorough testing! This is defintely a bug and it started for me recently as well.


I use the watch mostly for tracking cycling. Today's 15 mile ride was split up into 3 "workouts"

Workout 1 - 1 mile, started from widget. stopped tracking when I paused riding for 30 seconds.

Workout 2 - 6.2 miles, started from widget. stopped tracking when I paused riding for 60 seconds.

Got frustrated and resatarted the watch at this point...

Workout 3 - 8 miles, started from inside the Samsung Health app on the watch. Tracking did not stop and I was able to complete tracking by "finishing" the workout on the watch. 


Somewhere between the restart and starting the workout from the Samsung Health app it seems to have worked better. I'll try it again in a few days.



I've been having this issue for a few weeks now and it seems to be completely random - I usually track walking, running, cycling, yoga and circuits and it has glitched on all of these whether I'm connected to my phone or not and whether autodetect is turned on or off on my watch.

No probs! I just want to help get this issue resolved ASAP.

Nice solid report. Do you have auto-pause turned on during your tracking?
Interesting that restarted the watch seemed to make a difference. Maybe there's some aggressive memory management going on that is basically 'closing' the app when it crosses a certain threshold...

So difficult to figure out because it just seems totally random with how long a workout will go on before it stops tracking!
First Poster

Same problem here. Hope this'll be fixed asap.


I do have auto-pause turned on and in my limited testing it seems to crash during the pause. Do anyone in this thread have a ticket open with Samsung?



Just got in touch with Samsung and it sounds like they are aware of the issue and are working on it. Here is the response I received:

"Yes, this is already reported to us and we are working on it as soon as possible. I appreciate you reaching to us to report about this, No worries, we will make sure this will be resolved immediately."

Top Liked Authors