Open search

Galaxy Watch Stops Recording work out part way through


So this is really annoying now.  For months the watch has been fine but a couple of weeks ago now I got half way through a run and the watch stopped recording.  I use the watches work out app, select running (basic work out) and press start.  It records for about 10 minutes and then stops.   So a couple of days ago I set the screen to stary on during the run and it was fine for one run.  I ran again today and again it stoped after about 2km; no record of the run at all.  Any help would be greatly appreciated.

188 REPLIES 188

Does Samsung monitor these forums?  After having my Active 2 smartwatch since april of 2020 i've had to factory reset it two times to just get basic functionality to continue to work as expected, so a bit begrudged having to do it again.  I'd reccommend not taking the factory reset as a final solution to this and users continue to press Samsung via their support channels to actually investigate fix this issue as i think this thread demonstrates that this 'bug' isn't a rare or isolated problem.

New Member

This has started happening to my watch too, has it been fixed yet?

No Samsung hasn't fixed. Try doing a factory reset. It fixed the problem for me.

New Member

That problem is with me too for the past 3-4 month. It was usually happening after the 1st km and it was not that much of a pain.

Yesterday my training was ruined as I was not even able to track the intervals timing. I had like 5 glitches. After 1st km, then after another minute, then after 3 minutes. I restarted the watch and it managed to record 6:30 minutes. Then I just stopped trying and it recorded the rest of my training as automatic activity for the remaining 12 minutes.
On complete other point the integration with Strava is not working correctly for months now, I usually extract GPX from SHealth, transfer it to a PC and upload it manually to Strava to get the correct results.


I spoke to the Samsung support team who said it was probably a hardware issue and I would have to send my watch back for repair. I tried to persuade them it was properly in the software and they should treat it as a bug and I also pointed them to this thread but they didn't seem very willing to listen. they are only offered for the watch to be sent for repair so I took up this offer and have sent it back. I'm pretty sure they will find nothing wrong!! but maybe if I do this and then still have the issue they might take it more seriously. Their support team is really not very good.

First Poster


How frustrating! How can it be a hardware issue when we are all having the same issue, after a software update!?!?! Honestly!

First Poster

My watch has started doing this only this week. I'll be walking and it will just stop. I'll restart it, it will just stop. SOOOO frustrating! Like many others here, it's only happening after a recent software update! Hopefully Samsung sort it given this is exactly what the watch is marketed to do!

First Poster

I guess it's a memory problem. The app writes some unknown data into the memory an the recording stops, when it's full. This explains, why resetting the system helps. If I'm right, we will have the same problem again, after enough time has passed.


Maybe you have auto pauze on

To turn it off:
on your watch you go to APPS

open health app
scroll down until you see the 'workout' section, it s a green running man 
open it

click 'training'

then scroll through your workouts, hover over the training that you want to do without the autopause

three little white dots will appear next to your chosen training

click the white dots

scroll till you see 'auto pause' (the fifth option)
and uncheck it

Hopefully this will fix it.

Top Liked Authors