Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

WARNING NVIDIA GPU Users: Do not buy a Samsung TV

(Topic created on: 11-01-2023 01:29 PM)
5470 Views
b_chleb
Journeyman
Options

There are countless posts on various forums about users of 3000-series NVIDIA GPUs having major problems with their Samsung TVs. These include:

-Not being able to set the refresh rate above 60 hz

-Not being able to use RGB and other color settings

-Not being able to enable Game Mode, input signal plus, HDR etc.

Basically, these TVs seem to have some kind of flaw with their HDMI 2.1 ports or their firmware (or both) that makes them incapable of properly communicating with these graphics cards.

I have this problem with my own TV (Q95A) after upgrading from a 1080 TI (worked fine) to a 4080. Samsung refuses to acknowledge this is a problem with the TV and I doubt it will ever get fixed. Their support just blames NVIDIA, even though other companies had similar issues with their TVs and ended up fixing them.

If you want a TV that works well with your PC, I strongly suggest you avoid all Samsung models.

38 REPLIES 38
Members_hd2iu3
Journeyman
Options

I think in order to enable VRR on this TV an HDMI 2.1 cable is needed, at least this is what I read in the internet. 

On my Windows 11 the OS Setting for VRR is ON and on the Nvidia Control Panel G-Synch compatible is also ON for the Samsung TV. However, on the Game Mode Interface I see that VRR is off as well as the Game Motion Settings - so I believe VRR is not working.

I have tested a few games and I did not encounter any issues like tearing or massive lag.

The settings which are working with my HDMI to DisplayPort:
Adjust desktop size and position --> select full screen and perform scaling on Display.
Use 4096 x 2160 and make sure that in the Windows settings you have the same resolution and 120 Hz (not 119hz)

0 Likes
jonq80b
First Poster
Options

So far my Samsung Q80B has not been detected by my RTX 4070 twice.

The fix for me each time has been reinstall the Nvidia drivers.

During or after the driver reinstall, my Samsung TV plugged into the 4070 HDMI port is detected again.

I noticed that this issue occurs after a new version of Nvidia drivers installed and my Samsung TV, display 2, is not being used as a display, showing only on display 1.

So far reinstalling the Nvidia drivers has been the only fix for me.

0 Likes
Lafegob
First Poster
Options

MANNN !!! I LOVE YOU . AFTER TWO LONG YEARS HAVING THIS WIERD ISSUE . I WAS able to Finally!!!!! fix it  ( not the expected way .... shame on you Samsung)  Using a 8k120hz HDMI splitter as you said. WORKED LIKE A CHARM. before that i had to disconnect the hdmi several times. 

My geforce 2060 doesn't have the same problem. Which means that there is a problem on the 3000 series and maybe further . and i see that it happens on the samsung hdmi detection. 

0 Likes
Members_hd2iu3
Journeyman
Options

Hey hey - I am glad that it worked for you 🙂 

Enjoy and happy new year!

0 Likes
dlbroussard
First Poster
Options

I've tried using an 8k 120hz HDMI splitter and it didn't work for me, but I'm willing to try it again. Can you share a link to the splitter you used. I'd really appreciate it.  Thanks in advance.

shrralis
Student
Options

I probably have the same problem with the S95C I got a month ago.

I don't have any PlayStation or Xbox but trying to connect my PC (RTX 3080 Ti) to the TV via a certified 3m (10ft) HDMI 2.1 cable. Sometimes everything is more or less fine (black screen appears for 1-2 sec not really frequently), but sometimes the TV can't stop showing me those black screens and sometimes it even loses signal (says No Signal).

I found a guy on YouTube (not sure if I'm able to post links here but the video is called "S95C HDMI Black Screen Issue" by the GamingTech channel) and he says that for him the solution was to buy a fibre optical cable because regular HDMI cables have some voltage losses and that's normal but probably those losses are too much for Samsung TVs.

So I've ordered an optical HDMI cable to try it out, hope to get it next month, so I'll get back to you with my findings on this.

Btw, some people say some HDMI splitters helped them and I think it might be true in case those splitters work as amplifier of signal or something, so they reduce those voltage losses in the cables (that's just my assumption that would explain some things).

0 Likes
shrralis
Student
Options

Well, what I can tell you, this optical HDMI cable (FIBBR 8K HDMI 2.1 Cable) does its job for me.

I've finally got rid of those drop-outs on my TV. Not sure about 144Hz, but 4k 120Hz works like a charm.

It's a bit troubling in my case because the "first connection" is not successful (No Signal screen), but after going to the HDMI Troubleshooting in Settings -> Device Care, it starts somehow and then works like a charm. A couple of hours in Game Mode in 4k with HDR  without a single black screen.

 

UPD: another way to fix the handshake (No Signal screen) with this cable for me is something with the Game Mode, turning that off and on several times fixes the issue (maybe also changing the screen ratio via Game Mode menu 16:9 -> 21:9 -> 16:9).

kovsebi
Apprentice
Options

RTX3080 mobile and S95C. It makes the same mistake. It is unusable.... It also fails with HDMI and USB-C. It works perfectly with XBOX series X and Playstation 5.

jonq80b
First Poster
Options

This is what fixed it for me.

With Samsung TV not detected, powered on, set to PC Input (example: HDMI 4 eARC Game Mode), and connected to my RTX GPU (4070) via new HDMI cable...

On working monitor / laptop screen, go to NVidia GeForce Experience

Click Drivers, then the 2nd set of 3 dots, then Reinstall driver

Screenshot 2024-01-16 100434.png

After I did this, my Samsung TV was detected and has not given me any problems for a few months.

I realize this may not work for you guys, but just sharing what fixed it for me.

0 Likes
Kabbi
Journeyman
Options

Sorry for very late reply. It made things better. Less drops, but the problem is still there. I heard and read that it work great with fiber optical hdmi 2.1. I ordered this expensive cable. Will come back here with results. 

0 Likes