Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

WARNING NVIDIA GPU Users: Do not buy a Samsung TV

(Topic created on: 11-01-2023 01:29 PM)
5467 Views
b_chleb
Journeyman
Options

There are countless posts on various forums about users of 3000-series NVIDIA GPUs having major problems with their Samsung TVs. These include:

-Not being able to set the refresh rate above 60 hz

-Not being able to use RGB and other color settings

-Not being able to enable Game Mode, input signal plus, HDR etc.

Basically, these TVs seem to have some kind of flaw with their HDMI 2.1 ports or their firmware (or both) that makes them incapable of properly communicating with these graphics cards.

I have this problem with my own TV (Q95A) after upgrading from a 1080 TI (worked fine) to a 4080. Samsung refuses to acknowledge this is a problem with the TV and I doubt it will ever get fixed. Their support just blames NVIDIA, even though other companies had similar issues with their TVs and ended up fixing them.

If you want a TV that works well with your PC, I strongly suggest you avoid all Samsung models.

38 REPLIES 38
Members_hzhxN5O
First Poster
Options

Thank you, your post guided me to a solution. In fact, one needs to select in resolution not 4k * 2k but scroll a bit lower for the same resolution but written out 4xxx * 2xxx under 'PC'. Afterwards, can select 120 Hz and 10-bit colors. 

0 Likes
Members_JFRP5vf
First Poster
Options

QN90B 43" + 4080 here with random permanent signal loss on NVIDIA HDMI port until reboot.

Running nvidia-smi remotely shows display is "off" although the QN90B is "on".

Input Signal plus on and am using a 8K certified HDMI cable. Firmware is 1430.1. Sometimes the TVs backlight is confused when turning the TV on while the PC is running, it only partially lights the background then and is pumping.

This happens randomly when PC is running and TV ist turned of through the remote. Display is at 4K, frequency is irrelevant: this happens at 60, 100, 120 and 144 with or without Gsync. Gamemode does not matter either, when windows screen saver is running it happens quicker.

0 Likes
Members_hd2iu3
Journeyman
Options

I have the same issue with my S95B and RTX 4090 (Windows 11)

- Bought a certificate HDMI 2.1 cable (with QR code / 48gbps)

- Updated Samsung TV to firmware 1520

- Updated to the newest driver from Nvidia for RTX 4090 and executed a clean installation

- Connected a second monitor to try out different settings in the Nvidia Control Panel

I am able to activate Input Signal Plus with VRR ON, HDR OFF at 120hz and G-Sync compatible. However, as soon I activate HDR the TV loses connection, changing color format does not help. So running color format ycbcr420 (full RGB) with 8bit  with HDR Off works fine.

I also turned off fast startup, didn't change anything.

If you have any experience or recommendation, I would be very glad to try it out, any help is welcome.

0 Likes
Finn92
Journeyman
Options

In my case, I was either a moron or the OC-box has over heating issues. I used a Philips hue sync box, and it only supports 4K 60 or 1440p 120 (only after fw-update). When I moved the oc box out of the cabinet, the signal drop issue disappeared! Either I did not test pc directly in oc box (sure I was, but this was in march), or the heat building up in the cabinet was the problem. 

0 Likes
giamba23
Explorer
Options

This is how these dropouts look like on my 55" QN95A with ASUS TUF 4070Ti OC:

Done some tests, I was able to achieve a stable signal with HDR enabled only at 60Hz and 2K resolution (ridiculous). Here is a table showing what I've tried:

photo_2023-09-09_20-32-09.jpg

I really hope samsung steps in and solves this problem

0 Likes
giamba23
Explorer
Options

Does it still working for you? For my QN95A 55" this solution not working, unfortunately

0 Likes
Members_hd2iu3
Journeyman
Options

Most likely a HDMI Handshake issues occurs. That means the source doesn't accept the keys from HDMI Distribution equipment. During the handshake, the devices exchange information like resolution and color output to enable HDR. In this case, the only handshake that works for you is 60Hz and 2K resolution. I got the same problem.


The reason for an HDMI handshake is that Nvidia has HDCP encryption enabled by default. You can not disable HDCP at all, Nividia does not allow it and do not supply any patches to allow that.

However there are HDMI Splitters that actually disable the HDCP by accident. What happens is when using an HDMI Splitter, one of the receiving HDMI devices authenticates the HDCP Encrypted Key and this permission then allows the second HDMI Device to receive the disabled HDCP content.

That solved the issue for some people, but I did not tried it yet. I ordered a HDMI 2.1 to Displayport 1.4 cable to try if that solves the issue - we will know soon. 

Members_hd2iu3
Journeyman
Options

I was able to solve my problem with an HDMI to DisplayPort cable: Lindy 1m DisplayPort to HDMI 8K60 (From Lindy Electronics).

Now I can turn on HDR with 120hz. I will try later to turn VRR on, but for now everything is fine. 

giamba23
Explorer
Options

Good to hear! 

By the way I've disabled HDCP  via windows registry editor (and saw it actually disabled in the nvidia control panel) but the problem persists.

As for now I've reached 4K 120Hz VRR using custom color settings in the nvidia control panel:
Output color depth 8 bit and color format YCbCr420. This is with certified HDMI 2.1 cable.

Obviously with these settings one can forget about HDR.

Will wait you to test your setup with VRR enabled.

0 Likes
b_chleb
Journeyman
Options

If nothing else works, there is one thing I noticed while fiddling around with this for many months. I found that the results of plugging the HDMI cable into any of the slots on the TV's OneConnect box are completely inconsistent. Sometimes it only lets me set the refresh rate to 60 with no HDR, other times it works perfectly (4K, HDR, 120HZ), and sometimes it doesn't detect the cable at all and tells me there's no device plugged in. 

This might seem like a silly solution, but if it's not working, keep unplugging the HDMI cable and plugging it back in to see if you get a different result. That's how I seem to have "solved" it in the end.

It sucks, and it messes up constantly, forcing me to unplug the cable and plug it back in until it works again, but I am often able to get it working for a week or two at a time.