Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung q80t 4k 120hz work in all ports

(Topic created on: 12/11/20 04:48)
Michael388
First Poster
Options
TV

So. Bought Samsung q80t, connected to it laptop with video card rtx 2060 in port  tv hdmi 4. In the settings only 2560x1440hz mode. No 4k 120hz. Then I bought a new hdmi cable version 2.1. Again there is no 4k 120hz.  Then I downloaded the utility cru resolution and could get 4k 120hz. Vrr with hdr 4k 120hz worked great.  Then i connected to the laptop my old hdmi cable ver 1.4. 4k 120hz working great  vrr with hdr works in all ports  hdmi ( hdmi 1, hdmi 2, hdmi 3, hdmi 4) with my old cable. How can this be?

Firmware 1402. 

 

 

0 Likes
Reply
3 REPLIES 3
Larsson24
First Poster
Options
TV

You need to have hdmi 2.1 on your graphics card. Only RTX 3000 series and Radeon 6000 series have it. 

0 Likes
Reply
Denni5M
Explorer
Options
TV

Yeah I was getting 120hz on Hdmi 3 as well on my 3070, I couldn't use HDMI 4 because it would flicker and cause issues because this model has issues with HDMI 2.1 at the moment. 

But you will find it's only 4:4:2 when using HDMI port 3, you still get 120hz 4k though. 

I didn't have to even setup a custom resolution or use CRU, it's just available in the PC list of resolutions listed. 

0 Likes
Reply
ExtremeBalls
First Poster
Options
TV

Hey my dude. I got my 3090 a couple of days ago and I have a Samsung 80T 65inch. I bought a Belkin Ultra HD High Speed HDMI Cable for $100 at JB. Connected 3090 to 80T VIA HDMI PORT 4 - Took a minute to gain signal. Went on my pc (Windows 10) - Display Settings - Clicked on the display - HDR ON - Display Resolution 4096 x 2160 or 3840 x 2160 - Advanced Display Settings - Refesh Rate 120.000 Hz. Then (Went to my Samsung 80T Settings) Turned on Game Mode. Works like a charm. Here is the HDMI I used as a link - https://www.jbhifi.com.au/products/belkin-ultra-hd-high-speed-hdmi-cable-2m

0 Likes
Reply