Support

Open search

Q95T Game-Mode Green/Purple/blue Tint

Voyager

20200829_084526.jpg

20200829_084505.jpg

20200829_084446.jpg

20200829_084511.jpg

20200829_084500.jpg

20200823_225441.jpg

20200823_230455.jpg

20200825_113814.jpg

20200825_113829.jpg

20200823_225049.jpg

20200823_225107.jpg

20200823_225441.jpg

  

20200823_230607.jpg

20200823_230455.jpg

After 55'Q95T updated to the latest firmware 1304 there is lots of green/purple/blue tint when darker areas or around some objects displayed in Game-mode. Also the game mode performance and local dimming degraded when compared to the previous versions. Already there is a dimming bug in game-mode everybody is complaining (link given for the dimming  bug: 

UK samsung forum link:
 
US samsung forum link:
 

 

now new problem introduced by the amazing scamsung firmware developers team. attached some photos.

 
Note: photos taken by connecting multiple devices like xbox one x, ps4 pro, pc by using premium promate HDMI cable capable of transfer full bandwidth of HDMI 2.0b with TrueHD7.1 and HDR 4k 60p simultaneously also tried with the stock cables given by Console manufacturers. This is not the cable or Console issue. In TV's game-mode everything default.
 
Edit: updated to version 1402.7 still it is there. No fix
 
22 REPLIES 22
Helping Hand

Can’t see any pics? 

Refresh uploaded 

Pathfinder

Try setting the HDMI black level to LOW (from External Device Manager setting on the TV)

No thats not solution. Everything in default. Setting HDMI black level to low would crush blacks to the deep. Hdmi black level low is for HDR content only

Apprentice

It seems like this update really messed up... wow. 

 

- Does this also happen with Game Motion Plus ON? 

- Also, does it happen when receiving a 120hz signal (via PC or Xbox one X)?

 

Thank you.

Yes with GMP on it happens. Not sure about 120hz signal. 

Explorer

This Update really sucks. Got the inverse ghosting issue...

Voyager

20200829_084446.jpg

20200829_084500.jpg

  

20200829_084526.jpg

20200829_084505.jpg

Navigator

i have the same artefacts (purple/green) / ghostings probleme on my q80t, i'm so mad...

 

 

Top Liked Authors