Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Q90R No Signal from Windows 10 PC with Input Signal Plus Enabled

(Topic created on: 06-07-2021 06:58 PM)
IIGrayFoxII
Apprentice
Options

Hi All,

 

I'm having some fun and  games with my Q90R having connected it up to my Windows 10 desktop PC (via NVIDIA 1080GTX HDMI 2.0 port). I'm currently trying to get HDR working from the PC on this screen at any resolution 1080p 30Hz/60Hz, 4K 60Hz, but there seems to be what I can only describe as some sort of handshake type issue between the TV and the PC because as soon as I enable "Input Signal Plus" on the HDMI port at the TV, the TV loses signal and my primary monitor flickers continously as it detects the TV and then drops connection. This problem also persists whilst using only the Samsung Q90R too. As soon as "Input Signal Plus" is turned off, it all works just fine, only I cannot enable HDR at all. It works flawlessly at 4k 60Hz, 1080P 120Hz but this is baffling m.

 

I've tried a variety of short HDMI 2.0 cables which I know work from my PS4 Pro and XBOX One X (1.5m - 2m length), and have tried using all of the HDMI ports from the One Connect box, but the problem persists. I do have a HW-Q70R soundbar also connected to the One Connect box with ARC enabled, and will look at eliminating that shortly.

If anyone else has had a similar problem and found a way to get HDR working via Input Signal Plus without the Windows PC having a total head-fit and found a solution they could share, I'd be most appreciative. I've had a search on the forum and spent a couple hours on google but didn't turn up a whole lot.

 

Kind regards.

60 REPLIES 60
Andremi
Journeyman
Options

Hmm..did not try HDMI 4. Thanks,  will try that later.

0 Likes
xown
First Poster
Options

Good solution: go to windows settings, power options, advanced. Change the settings for power buttons. Just untick "Turn on on fast startup".

No loses of signal after that.

0 Likes
Leon42
First Poster
Options

What helped me was switching my PC to HDMI4 AND turning off "fast startup". My TV is Q80R and my problem was that the PC didn't boot when the TV was connected with "Input Signal Plus" enabled.

0 Likes
nu1mlock
First Poster
Options

Turning off "Fast Startup" did nothing to help me.

I have a Q95T and an RTX 3080. When TV and monitor are connected at the same time the signal to the TV is lost. As soon as the monitor is disconnected the TV will get a signal again and work.

When my monitor is connected my PC will lose signal if Input Signal Plus is connected. I can enable it if I disconnect my monitor, but if I connect it again I will lose the signal to the TV.

I have tried all three DisplayPort-ports on my GPU. I have also tried booting my PC with/without monitor and with/without TV. Nothing matters - if my monitor is connected I will lose the signal to the TV if Input Signal Plus is enabled.

0 Likes
Alpro
Explorer
Options

The problem is within your color settings on your pc i think. This solution worked for me, hope it helps:

"Ok, heres my fix.  use Custom Resolution Utility to 'reset all', then 'restart'.  Set the resolution to 4k 60hz.  Once there put on game mode (which enables Input Signal Plus).  Once monitor is at 4k 60hz with input signal plus on, 8k Native res should appear.  I clicked enable 8k resolution with 4:2:0 10bit (nvidea control panel).  It didnt work 5 times, keep trying, and randomly it works.  The key seems to be YCbCr420 mode (4:2:0).   GLA - props to Wickfut for helping."

0 Likes
nu1mlock
First Poster
Options

Sorry, but 4:2:0 is simply not a solution to the issue. It is also not possible to set 4:2:0 unless I disable "Input Signal Plus". If it is enabled only RGB, 444 and 422 is available. In either case, the correct selection here is RGB.

You get extremely downgraded visuals and color banding when using 4:2:0. The TV supports both RGB and 4:4:4 on HDMI 4.

4:2:0 is enough for movies, since that's what they use, but PC games and PC usage - especially browsing - need more color information than what 4:2:0 can provide and will make your text unreadable. In either case, it is not the proper usage for the TV and an RTX 3080.

0 Likes
Breinz
First Poster
Options

So I know this is an old thread but I'm posting in the hope this helps someone out. I was having the same/similar issue on my TV where UHD worked fine at 60hz until I turned on signal plus so I could enable HDR in Windows. As soon as I did that the TV would switch to 30hz and couldn't pick up a 60hz signal at UHD resolution. Disabling signal plus brought back 60hz...but no HDR. I tried everything, verified I was using a proper hdmi 2.0 cable, all the settings on the TV people have suggested online, different ports. That's when I stumbled on the attenuation limits of hdmi. I was using a 10m cable as my pc is on the other side of the room. Now I see op has tried short cables and whilst looking I've seen UHD 60hz is allegedly supported by hdmi 2.0 but I don't think 120hz is. I think a 2.1 hdmi cable of no more than 3m is required - in my case I bought a 10m fiber 2.1 cable because I can't do anything about the distance and its instantly recognised the signal and I can finally play in HDR at 60hz in UHD. It was only £20 on Amazon, but I think this may be the issue for most people. Again, I don't completely know if 2.1 is required but for the sake of a couple of pounds just get a short 2.1 or a fiber 2.1 hdmi cable if distance is an issue.

BjornByrne
First Poster
Options

Just incase you thought you were alone in the PC world, I have the same problem with Mac. Running latest M2 pro chip which runs hdmi2.1, HDR, VRR up to 144HZ etc etc and the moment you select input signal plus to take advantage of all these great features, the TV gives you the finger. This is on a QN90B... I've got a high spec HMDI2.1 cable and have checked all else thoroughly, it runs sometimes and other times just plain refuses to work until you're forced to switch Input Signal Plus and Game mode off. Samsung, this is ridiculous, can you not see your customers struggling on this matter for years now, why can other manufacturers fix this but you can't? Your hardware is clearly capable of running this, so your software needs work here... 

0 Likes
Breinz
First Poster
Options

Hi Bjorn, how long is your HDMI cable? Your issue sounds the same as mine, if it's longer than 3m then I can pretty much guarantee that's the problem.

0 Likes
Roms47
Explorer
Options

Sadly this problem looks like it persisted across so many models. I’ve got a qn900b and after close to year I might have solved this for me. I’ve got a 3080 card…

​Input Signal Plus is obviously on for the Hz to climb over 60 and Gaming Mode is on for the Sound to work properly...for some reason the sound glitches when game mode is off.

Here are the setting that I changed to make it happen.
* Open the NVIDIA Control Panel
* Click on Adjust desktop size and position
* Select the Override the scaling mode set by games and programs
* Select Perform Scaling on Display
​* I'm using 4K - 3840 x 2160
* Set the Refresh to 100 or 120 Hz

At times the setting here changed, so to get it to stick to 100 Hz for now...I followed the following steps
* Open Display Settings
* Scroll down to Advanced Display Settings
​* Select 100 or 120 Hz in the Refresh Rate section...this seems to hold the setting steady.

I don't want to celebrate too much, but after multiple PC and TV reboots, this seems to have stuck and it working fine. I can see the framerate in multiple places...finally I can enjoy the TV as intended lol!