Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Q90R No Signal from Windows 10 PC with Input Signal Plus Enabled

(Topic created on: 11-05-2021 09:46 AM)
2348 Views
IIGrayFoxII
Apprentice
Options

Hi All,

 

I'm having some fun and  games with my Q90R having connected it up to my Windows 10 desktop PC (via NVIDIA 1080GTX HDMI 2.0 port). I'm currently trying to get HDR working from the PC on this screen at any resolution 1080p 30Hz/60Hz, 4K 60Hz, but there seems to be what I can only describe as some sort of handshake type issue between the TV and the PC because as soon as I enable "Input Signal Plus" on the HDMI port at the TV, the TV loses signal and my primary monitor flickers continously as it detects the TV and then drops connection. This problem also persists whilst using only the Samsung Q90R too. As soon as "Input Signal Plus" is turned off, it all works just fine, only I cannot enable HDR at all. It works flawlessly at 4k 60Hz, 1080P 120Hz but this is baffling m.

 

I've tried a variety of short HDMI 2.0 cables which I know work from my PS4 Pro and XBOX One X (1.5m - 2m length), and have tried using all of the HDMI ports from the One Connect box, but the problem persists. I do have a HW-Q70R soundbar also connected to the One Connect box with ARC enabled, and will look at eliminating that shortly.

If anyone else has had a similar problem and found a way to get HDR working via Input Signal Plus without the Windows PC having a total head-fit and found a solution they could share, I'd be most appreciative. I've had a search on the forum and spent a couple hours on google but didn't turn up a whole lot.

 

Kind regards.

62 REPLIES 62
Big Moose
First Poster
Options

I think I found the solution and thought I'd share it.

My assumption is the TV (Samsung 75Q85R) is at fault as it fails to detect the PC is capable of HDR after a power cycle, and fails the HDMI handshake - Hence it disables the Input Plus, and causes all sort of problems with the PC not recognizing whether the "monitor" supports HDR or not. This is supported by the fact that many mentioned the issue does not happen with an actual PC Monitor, which puts the fault squarely on Samsung shoulders.

Anyway, I thought I'd try to an use an HDMI EDID emulator - I used the Lindy one here but there may be cheaper options:

https://www.lindy.co.uk/audio-video-c2/hdmi-2-0-edid-emulator-p11244/s11404?utm_source=google&utm_me...

The only thing is, I didn't exactly use it as they documented. What I wanted was to capture the EDID from the Samsung TV with Input Plus (HDR) enabled. Once done, leave it plugged on the source in order to tell the PC that the display supports HDR no matter what my Samsung TV does.

The "tricky" part is to have the HDMI EDID emulator learn the Samsung TV EDID with HDR enabled, as it keeps on disabling Input Plus. You may have to check both these points before you start HDMI EDID emulator learning process:

1-  Windows shows HDR is enabled

2- Input Plus is enabled

I have now been tested few power cycles, as well as putting my PC to sleep and waking up again after switching the TV on/off, and everything has been stable up to now.

I ordered the HDMI EDID emulator from Amazon and it comes in a resealable bag, so you can send it back if it doesn't work.

I'm still curious if this works for other people though. Please let me know.

0 Likes
xown
First Poster
Options

Q95T. The problem is still there. Set signal plus (required for HDR) and your PC can't restart(loses TV signal).

But:

1. If I wait toooo long. Cup of tea. It will load! (without signal plus it loads in seconds)

2. You can load withot signal plus and then enable it. Just don't forget to turn it off before PC shutdown

3. If I turn off my PC after signal lost, my Dell turns on for 3 seconds and turn off again. After that it loads fine with all signal plus. But next restart will be the same. 

Problem is in a handshake between GPU and Samsung. LG fixed something similar recently.

Some people complain about game mode, but it is just the same. Game mode requires signal plus.

Things don't help me and many, but few people think it helps them:

- Another shorter cable. 

- Fast boot disable. Or compatible mode.

0 Likes
Big Moose
First Poster
Options

I found that everything works as expected as long as I switch the TV  on before I start my PC. As long as the TV is on, I can safely restart, put to sleep & wake up, turn off and back on without issues.

If ever I accidently turn the PC on while the TV is off, then I sometimes get "No signal" (Unsure why it doesn't always happen). I then need to unplug and plug the HDMI to have Signal Plus / HDR recognized properly.

It doesn't seem to matter whether the right HDMI input is selected - Only thing that matter is the TV needs to be on.

It has been working like that for a month without any issues.

0 Likes
odyssey96
First Poster
Options

If you turn your PC on before your TV and when you then turn your TV on you have no signal, hold CTRL, SHIFT, Windows key and press B to reload your graphics drivers which for me then shows the signal.  No need to restart anymore for me

0 Likes
Andremi
Journeyman
Options

Unfortunately none of this works here. It does not matter if I turn the TV on first or last. Resetting the graphics driver in Windows makes no difference. Switching to Signal Plus kills the signal no matter what. I'm running latest Nvidia drivers and latest Samsung firmware.

0 Likes
odyssey96
First Poster
Options

Have you opened Nvidia control panel and select resolution from there?  There will be both 'tv' resolutions and 'pc', I select pc resolutions for input signal plus.  Chicken and egg scenario, pc resolutions might not be available until input signal plus enabled - so what I've done is use team viewer or moonlight to set it remotely and restart from there.

0 Likes
Andremi
Journeyman
Options

Sadly still a no go. I changed to a "pc resolution" from within Nvidia control panel. Changed to "signal plus" on the TV, boom, signal totally lost. Did the ctrl+shift+win+b but no luck.

0 Likes
odyssey96
First Poster
Options

Restart now?  You're in hdmi 4 too?

0 Likes
Alpro
Explorer
Options

My issues with these monitors, regarding input signal plus and no signal is all to do with the settings you have in windows.  You want to go to NVidea Control Panel, and ensure the Output Colour Format is "YCbCr444, or 420".   hope that helps.

0 Likes
odyssey96
First Poster
Options

Doesn't that just highlight the cable you have might not have the bandwidth for full HDR output?  You're reducing the range right?  I'm on full range, running 4k120

0 Likes