Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

No terrestrial / Freeview on my new smart tv.

(Topic created on: 31-01-2020 01:12 AM)
105098 Views
Highlander52
First Poster
Options

Hello, I have a new Frame tv and it's set up with Wi-Fi and the One Box is connected to aerial socket, but there are no terrestrial / Freeview channels. I've tried auto-tuning and resetting on numerous occassions but still nothing. What am I doing wrong? Thanks. 

71 REPLIES 71
NickiH
Apprentice
Options

This is part of a post I did a few months back.  I hope it helps!

I found this solution and IT WORKED!  

  • go to the Samsung TV Plus channel list
  • select 'Edit Channels'
  • Press 'select all' (top right on my tv) and then DELETE all channels
  • autotune option then appears as it shows no channels available
  • Follow autotune instructions as prompted

NOTE: We ended up with 150 digital tv/radio channels!  Please make sure that your terrestrial cable (coax) is plugged into the back of your tv.  I forgot to do this first time round

0 Likes
NickiH
Apprentice
Options

I forgot to mention that this genius solution isn't mine - it was posted by another user on here.  Good luck!

0 Likes
NickiH
Apprentice
Options

Hi Starnett, I used your solution a few months ago for my brother's Samsung and it worked so many thanks!  I'll be sticking with LG at my house!

0 Likes
ScottyG48
Apprentice
Options

It didn't work for me! All seemed fine, I deleted the channels then searched and found 140 channels. But they were all Samsung tv plus channels. No sign of basic terrestrial channels like BBC, ITV etc. Any thoughts?

0 Likes
NickiH
Apprentice
Options

Hi, sorry that you’re still having problems. It’s a ridiculous situation, isn’t it?
My only suggestion is have you checked that the coax cable has been plugged into your tv? I know this sounds really obvious but when I did this the first time round, it didn’t work because I hadn’t checked the coax!  I’d done the first retune with the coax still in my Virgin box.
Having made getting terrestrial so incredibly difficult, I can’t believe that Samsung would deliberately sabotage a work around! But then who would have thought they would have made getting terrestrial stations so difficult in the first place?!
I hope you find a solution as it is incredibly frustrating.

all the best, Nicki

0 Likes
ScottyG48
Apprentice
Options

Thanks Nicki! Yes it's definitely attached direct to my tv, I'll remove and reattach just in case, but it's certainly strange! 

0 Likes
ScottyG48
Apprentice
Options

Result! I finally have success using the method on this thread. I continued moving my indoor arial and finally got lucky. Thanks for the tips!

0 Likes
Beeb75
Apprentice
Options

Would you mind explaining exactly what you did please? I gave up ages ago. 

thanks 

0 Likes
Barry25
First Poster
Options

Yeah it’s a pain in the a** the way they have done this, the labelling on the back of the tv also wrong in my case. I plugged the aerial cable into the cable socket on the tv not the one labelled Ariel (🙄)  then you have to completely unplug the tv for a minute for it to reset then the channel tunings should come up and then boom tv!! 

0 Likes
ScottyG48
Apprentice
Options

Hi Beeb75. Partly perseverance! I followed Nicki's instructions so go into samsung tv plus, hit channel list/guide in the middle of my remote then chose edit channels at foot of screen. Select delete all channels and confirm. It then prompted me to search for channels which it found...eventually, after many frustrating attempts. Once it found them, Live Terrestrial TV suddenly showed up in my row of apps etc, next to samsung tv plus and, in my case, sky.

My issue was partly because I was testing a new indoor arial and I was having to move it around too to get a signal. 

Thanks to Nicki too, and the original poster too!

0 Likes