Open search

No sound with Kodi connected to One Connect Box (Samsung 75Q90R)


Hi all,

My first post here, so I hope I posted it in the correct section.

Anyways, I purchased a new TV (Samsung 75Q90R) about a week ago. Finally connected everything and everything is working fine except for my Kodi (Intel NUC). I get video, but I cannot get any sound. I have tried a ton of settings and even different (testing) video's and in some cases I actually managed to get sound. I think it was related to the audio source of the video; apparently when the source of the video has e.g. DTS-MA (or something like that) I cannot get any sound played.

Obviously you will need more details, so here goes. I have a Denon AV-receiver (AVR-X1400H), Entone (which is uses a seperate fiber internet connection for TV programs) and an Intel NUC (with Kodi installed on it).

I have my HDMI OUT on the Denon receiver (ARC) connected to the Samsung One Connect Box (HDMI #3 with ARC). I have the Entone (for TV programs) connected to HDMI #4. And I have the Intel NUC (Kodi; for streaming movies and such) connected to HDMI #2 (also tried HDMI #1).

Reason for the above is that I can control everything with the Samsung remote perfectly. I can switch TV channels with the Samsung remote on the Entone. Both video and sound (over my AV-receiver) are working fine. Also Netflix-app on the Samsung TV works perfectly fine (video and sound). So in the case of the Entone and Netflix I have video and sound is being played over the KEF speakers through the AV-receiver. So far all good.

The problem is the Intel NUC (with Kodi installed on it). No matter what I try or do (fooled around in Kodi settings along on the Samsung TV) I do get video, but I do not get any sound. Shouldn't it just pass the sound to the AV-receiver like it does with the Entone?

I did get sound at one point, but that was a different video with a different sound track (e.g. not DTS-MA or whatever it's called). I also fooled around with the passthrough settings in Kodi (among others), but also no succes.

The only way to make it work is by plugging the Intel NUC in one of the HDMI (IN) ports on the AV-receiver (at the moment HDMI #5). That way, I have video and sound without any issues. HOWEVER; I lose control over the Intel NUC with the Samsung remote. And this is really something I would want. This would mean I can ditch all remotes completely and only have the Samsung remote.

So I don't know if someone can help me (I will post this issue also on other forums), but I hope someone has some experience in getting an Intel NUC (with Kodi preferably ofcourse) to work correctly, in terms of sound/audio, with their Samsung One Connect Box.

I don't know if it's important to state the Intel NUC I have, but it's the Intel NUC 7i5BNH. And yes, I even updated it to the latest BIOS yesterday (the old BIOS was dated 2017). But that didn't help either. As mentioned Kodi is installed on the Intel NUC. The OS for Kodi I used is LibreELEC. I did fool around with various settings, but no luck so far.

Maybe someone has an idea? I am willing to try anything in order to get this working with the Samsung One Connect Box.

Thanks in advance for taking a look!


A small follow-up; which I forgot to mention. Apparently the Samsung 75Q90R does not support DTS codec (according to the specifications). So maybe that's the cause...

...however, since I the AV-receiver's HDMI OUT (with ARC) which connects to the Samsung One Connect Box on HDMI #3 (ARC) it should pass the sound to the AV-receiver, right? Maybe I am mistaken, but also could explain that a different video with a different audio channel (non DTS) worked before.
Top Liked Authors