Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

ITV Hub and All4 not working correctly.

(Topic created on: 19-01-2022 12:35 PM)
1537 Views
PCSviewer
Apprentice
Options

I have this: UE50RU7020KXXU

At present BBC iPlayer, Netfix and Prime all work fine.

ITV Hub and All4 did work, but not the apps load OK but when I select a programme all that happens is that the spooling symbol appears - and nothing else!

I have checked the firmware version which is up to date, I have reloaded the ITV and All4 apps, and 'cleaned' the apps.

But none of these works!

I have a hard wired 100Mb/sec internet connection. Any advice welcome.

 

10 REPLIES 10
TessM
Mastermind
Options

Hey @PCSviewer ,

 

I can see that an update was released in December for this TV (version 1374.0). Is yours running on this software version? Are these the only apps affected by this?

0 Likes
PCSviewer
Apprentice
Options

I have tried to update the software, but it claims to be running the current version. Both the online and USB method report the same, so I think that the software is OK.

I am also using BBC iPlayer, Netfix and Prime, all of which work perfectly.

Only the ITV and All4 apps are affected by this issue.

0 Likes
TessM
Mastermind
Options

 Is the TV showing this version when you go to the TV Settings> Support> About this TV? 

0 Likes
PCSviewer
Apprentice
Options

I confirm that this TV is running firmware version 1374. Auto update is on - 'update now' says that I already have the current software.

I have now reset the hub and re-entered the login info.

Apps which work are Netflix, Prime, BBC iplayer, My5.

BUT ITVhub and All4 do not work correctly - the index is shown but no selected programme will run. Any further thoughts on this issue?

 

0 Likes
PCSviewer
Apprentice
Options

I also tried to use the 'Internet' app. This allows me to log in to ITV Hub, but again, content fails to play. It just hangs as if spooling waiting for the download.

However, the internet connection is working at 100Mb/sec.

Any further thoughts.

 

0 Likes
Pamsy
First Poster
Options

I contacted samsung regarding the same problem playing itv hub yesterday. They mentioned all4 not working also. Their engineers know of the problem and are trying to solve it

0 Likes
SBV52
First Poster
Options

Ours hasn’t been working properly since we got it a year ago. Very very disappointing 

0 Likes
Members_UgNKSn6
First Poster
Options

I have a QE55Q60TAUXXU less than 12 months old, It was playing ITV Hub but for the last few weeks nothing. It was struggling to play More 4 but that seems to be ok. I've reset the Smart Hub. connect Samsung and they did the same thing remotely. still doesn't work.  Must be a software update !!!

0 Likes
M and S
First Poster
Options

I have same issues on my AU7100 except My5 is also not working. Cannot open the e-manual either. TV new for Christmas and all players working until approx 6 weeks ago. Tried all solutions suggested online and especially Samsung website. At a total loss and really like All4 for world dramas, so feel we have less than with old TV.

0 Likes