Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Apps storage space issue

(Topic created on: 03-12-2020 02:37 PM)
1750 Views
Tony47
Helping Hand
Options

TV: UE55 NU7500

I'm not sure whether this is a general Samsung issue or just to do with my TV, but the amount of space allocated to the Smart Hub apps seems to be seriously lacking.

 

As this is a new TV I thought I'd explore some of the available apps, but when I went into the Apps area I got a message saying that there was insufficient space to update apps. This was before I had downloaded anything, so it would purely apply to the pre-installed apps. 

 

I checked settings and the used space was 751MB with 64MB available, i.e. 7%. This seems absurd as these apps can't be deleted and are built into the system. The available space doesn't even allow them to be updated. I then tried resetting Smart Hub. This has helped to an extent as the available space is now 13%. However, it's still far too low and whenever I try and download a new app I get a warning about available space.

 

I can't believe that the pre-installed apps are taking around 700MB of space, and it seems crazy that Samsung would design the system this way. Presumably I will have to install an SD card to provide more space for the apps?

Any tips welcome as this is my first Samsung TV.

1,941 REPLIES 1,941
tinears
Apprentice
Options

Greetings all. Recently found myself laid up with a herniated disc in my spine so thought I'd take the opportunity to finally check out the smart features of my Samsung NU7120 I purchased 18 months ago from Argos in the UK. I'm sure you can all guess where I'm going with this...

 

Despite having never used or installed any apps on the TV (other than YouTube once or twice to check out the 4k playback), I'm greeted with the "can't complete auto update, delete some apps" warning. Apparently I have 62MB free space and need 139 to update. Auto-updates is turned on and the TV is running the latest 1310.4 firmware. I've deleted the few it would let me delete but that only freed up a couple of MB.  I've already read about 50 pages of this thread in the hope of finding a solution but apparently there isn't one.

 

Anyway just wanted to vent my frustration having only just discovered this issue 6 months after my warranty expired and to thank everyone here who have been trying to help. I'm gobsmacked at Samsungs lack of response and releasing expensive televisions with so little memory. If I'd known then what I know now...

Toxblh
Journeyman
Options
tinears
Apprentice
Options

Cheers, will look into it later. I'm a technically illiterate novice when it comes to smart TVs and phones (didn't own a smart phone until this year) and don't want to mess things up worse just yet. I hadn't been using the apps all this time I've owned it so was pretty happy with the set and unaware it had a problem until discovering this yesterday, which is what led me here. Think I really need to make a note of all my settings first in case I lose them.

0 Likes
RichardTV
Apprentice
Options

Says APPS (DEVELOP MODE) on the TV and app on Mac connects ok, and shows the list of apps. When I run the command to delete Netflix, I get this error:

 

Error! Please check you turn on developer mode and restart TV (Hold power button until startup logo) and try again. Msg Error: Command failed: /Users/---------/Desktop/Samsung\ Apps\ Remover.app/Contents/Resources/app/sdb/mac/sdb connect 192.168.1.175:26101

0 Likes
Toxblh
Journeyman
Options

Please to double-check Host IP with IP from the instruction p.4 and after changes to reboot your TV.

0 Likes
RichardTV
Apprentice
Options

It seems to be ok on the TCP ports 8001 and 8002, i.e. setting up the developer mode. When it tries to run your command and connect on TCP 26101 it fails, i.e. the TV is not listening on port 26101.

 

I confirmed this in Wireshark. Refer to screenshot were you first see an ICMP unreachable, then a TCP reset from the TV...

 

Snip20201203_10.png 

0 Likes
Toxblh
Journeyman
Options

Because 8001/8002 it's ports for remote control
26101 opens only via developer mode for developer SDB protocol and in allow only for inserted IP in the window:

devmode.png
If IP of PC (source) is does not match on TV  - SDB port will look like close.
As I see to your Wireshark - make sure you inserted IP in the developer mode popup is 192.168.1.52, also don't forget to reboot TV (long press to Power button on remote control until logo Samsung SMART TV)

0 Likes
RichardTV
Apprentice
Options
  • 192.168.1.52 is my Mac
  • 192.168.1.175 is the TV
  • Developer mode is on
  • There is definitely a TCP/IP connection, as the channels are listed in your app

In summary; the problem appears to be that the TV is not listening on TCP 26101 even with Developer Mode enabled...

Snip20201203_13.pngIMG_7481.jpg

0 Likes
RichardTV
Apprentice
Options

I checked a little further,. 

 

  • The TV is listening on TCP 26101 in dev mode - check NMAP below
  • I used the SDB app in your APP package and results in the text below
  • SDB on the command line = TCP RST from the TV
  • NMAP on the command line = TCP SYN/ACK from the TV

In conclusion - SDB is not establishing a connection properly for some reason.

 

iMac ~ % sudo nmap -p 26101 192.168.1.74
Starting Nmap 7.91 ( https://nmap.org ) at 2020-12-03 16:47 GMT
Nmap scan report for Samsung.broadband (192.168.1.74)
Host is up (0.097s latency).
PORT STATE SERVICE
26101/tcp open unknown
MAC Address: 70:2A:D5:7A:3D:84 (Samsung Electronics)
Nmap done: 1 IP address (1 host up) scanned in 0.26 seconds

iMac ~ % /Users/-----/Desktop/sdb connect 192.168.1.74:26101
connecting to 192.168.1.74:26101 ...
failed to connect to 192.168.1.74:26101

 

Note below that the TV sends an ICMP port unreachable with the SDB app and sends a TCP RST:

 

Snip20201203_16.png 

When I use NMAP to simulate the TCP connection, the TV responds with a SYN/ACK (i.e. TCP three way handshake):

 

Snip20201203_17.png

0 Likes
Toxblh
Journeyman
Options

Could you show photo with popup window enabling dev mode with Host IP?

Also
You send

192.168.1.52 is my Mac

And in the next message to do nmap for

192.168.1.74

Which IP do you insert to the Host IP?
I already see the problem with DHCP and Mac. When it changes IP in the network and you can't to connect to the TV.


So, I would like to confirm 2 base things
IP is your Mac the same which you insert in dev mode window on TV. Its main problem which could be prevented connection. I have the same TV and check with Mac - all works if all configured correct. But if change IP on TV and reboot it doesn't work. If IP is different I saw the same error.

 

0 Likes