Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Settings app search broken on Tab S7 FE Wifi edition

(Topic created on: 04-01-2022 04:45 AM)
Samson13579
Explorer
Options
Tablets

Settings app search suggestions broken on Tab S7 FE Wifi edition.

Settings search broken only when doing a search inside the Settings app, but the suggestion is working fine when using in Finder (swipe up on home screen)

When search in settings app, no matter you type in or pressing a hash tags, there is no result, only shows a loading circle icon.

Already tried to clear cache and storage for the Settings app and SettingSuggestions app but no helping.

I have done a factory reset then it appears to be working again, but after a few app install and updates, it breaks again. Don't know what the root cause is but it seems to be a buggy system updates.

1 Solution


Accepted Solutions
Solution
Michael Ponce
First Poster
Options
Tablets

No amount of factory reset/clear cache/clear data has fixed this for me.

A workaround that I am using is to uninstall updates for the Google Messages app. I found that using the factory version allows search in Samsung Settings to work while installing the update immediately breaks the function after relaunching the Settings app. 

To use this workaround, go to Settings > Apps > scroll down to Messages (by Google LLC) > tap the options (three dots on the upper right portion of the screen) > Uninstall Updates > relaunch the Settings app. To make sure this does not get updated (until this gets fixed), go to Google Play Store app > search for Messages (by Google LLC) > tap on options > uncheck "Enable auto-update."

Or you can simply uninstall the Google Messages app entirely if you are not using this app.

View solution in context

32 REPLIES 32
Samson13579
Explorer
Options
Tablets

Anyone have the same problem on similar Tablets? Not being able to search Settings is really annoying!

AndrewL
Moderator
Moderator
Options
Tablets

@Samson13579: If the issue was resolved with a factory reset, but reoccurred following the addition of third party apps, then the problem may be stemming from an external source. With this in mind, please restart your Tab S7 FE in Safe Mode by following the steps below, then try the search function in the Settings menu once again. Search for a known setting e.g Sounds and Vibration, and check to see if it produces any results. If it does, restart your tablet as you would normally and remove any recently installed apps.

To enter Safe Mode, press and hold the Power button until the 'Power off' prompt appears on the screen then release > Touch and hold Power off until the 'Safe mode' prompt appears then release > To confirm, tap Safe mode.

0 Likes
Samson13579
Explorer
Options
Tablets

I have tried your suggestion but with no luck.

Even in safe mode such that all external apps were disabled, the search in settings still NOT working.

i don't remember which apps were installed most recently so it is hard to debug. Is there a way to see the app installation log, including the exact installation or update time for each apps?

0 Likes
CarlH
Moderator
Moderator
Options
Tablets

Hi @Samson13579. If you open the Google Play Store app and then tap on your profile pic in the top right corner, tap on Payment and subscriptions and then on Budget and history, this should show you the date you installed all of your apps. 

0 Likes
Samson13579
Explorer
Options
Tablets

I finally fixed this problem myself! The root cause is an app called "Android System WebView"!

I did not install this app. When I was trying to debug by reinstalling some apps one by one, when it came to reinstalling "Android System WebView" would instantly solved this issue.

I do a quick google search and found out "Android System WebView" is a system component powered by Chrome that allows Android apps to display web content. So this is direct related to the searching function inside the Settings app, which make use of this component to render the search result. I believe this system component contains hidden bugs, but right now the problem was resolved by just reinstalling this component in the Play Store.

CarlH
Moderator
Moderator
Options
Tablets
0 Likes
Samson13579
Explorer
Options
Tablets

NO. Sorry I will have to re-open this issue just one day after accepting this as solution.

It was because just after one day "solving" this issue, the search settings function seems to be broken again without installing any new apps. So the "solution" by reinstall "Android System WebView" was simply temporary, or may be even just a coincidence. When I try to re-apply the same solution again, it didn't work at all!! Now the search function in Settings app remains broken.

I have a totally working fine Samsung Android 11 phone on hand, so I can do some comparison and provide more detailed info about the bug here:

1. In settings app, when pressing the magnifying glass, it should show some search history, but it shows nothing.

2. When pressing the three dot after the suggestion tags, it should show a list of available tags, but it shows nothing.

3. When typing in the search box and press enter, it should log into the search history, but it didn't. All I can see is just a forever loading circle.

So I guess there is a corrupted local database involved in the search process, such that it hangs the searching process? Perhaps when I reinstall "Android System WebView", it just coincidentally fixed a corrupted database and trick me into thinking that it solved the whole problem. But unluckily this is not a permanent solution. I hope someone can provide more information on this ANNOYING BUG.

0 Likes
DanielCh
Apprentice
Options
Tablets

In my case, it won't fix the problem, i'm uninstalling some apps, and after random number of uninstalled - the search works. 

After some apps installed it breaks again.

And it's always on system app.

I don't know which app... can't figure it, spent on this case a lot of hours.

Samson13579
Explorer
Options
Tablets

Hi, good to hear that someone is seeing the same bug, I am not alone.

Just a quick update that I have just temporarily "solved" the problem, again, by reinstall another app. This time the app is called "AAStocks" from the Hong Kong app store. It's been an hour from now, the bug still seems to be solved. However this app was totally not related when last time I "solved" the bug. I believe that this is not the root cause of the bug.

I really hope the devs from Samsung or Google can see my post and address this problem a.s.a.p.

 

0 Likes