Open search

Can't login to samsung websites by any browser and device



I'm trying to login to any European Samsung website like




and after I login with my credentials or with google, I'm sent back to the homepage (e.g. and the result is that I'm not logged in, no error or message telling about any problem. Deleting cookie, changing browser or even device (both pc and mobile phone) doesn't solve the problem, so it has to be some server side issue .

Actually I can login only if I do it in 



probably those systems are using a different login mechanism.

Last time that I had to buy something on the samsung portal I had to do it like a non registered user, providing the same email that I have linked to the non accessible account.

I tried to contact the customer services by email but they just said that I'm the only one with this problem and so they can't do anything, not even forward it to the right support team, I don't think is a type of answer that Samsung should give to somebody who bought TVs, mobile phones, gridges, etc for years and years.

I hope any of you could help me to solve this problem or to escalate it to the right people.




Hi @sanangeles.


I'm UK based, and was able to login to the US Samsung site with the same Samsung account without any problem. But I tried logging into some other European Samsung sites and had the same result as you did on most of them.


However, I noticed that there was a notice to update agreement to the Terms of Service on those sites when I tried to login. Once I'd clicked on the link, and then agreed/checked the boxes, I was able to login to those sites. I had to to do it for each site individually though. Any luck for you doing that?

 Say "Hello!" to the Community in The Introduce Yourself Thread.



Thank you for your support, unfortunately I don't find the terms of service agreement that you are talking about, or anything similar, I tried to see the full page and search for some text that could help me to find it.

At least I'm not the only one who had this problem.

Do you have any other suggestion of what I could do or who I could contact to try to solve it?

It was working until I asked to change my account from being related to one country (Italy)  to the new one I am living (Germany) and it is not something I couldn't do on my own so I contacted the customer care services, maybe they messed up something with the migration.


No worries, @sanangeles:smiling-face:


From what you've said it does point to something not being quite right with your specific account. In any case, I reckon it might be worth getting in direct touch with the Samsung Account team. Contact details might vary between different countries, but this link brings up the UK contact number for the Samsung Account team for me (08009951079), along with an option of a 'Contact us' webform.

 Say "Hello!" to the Community in The Introduce Yourself Thread.


Screenshot_20190623-235316_Chrome Beta.jpgHi


I am having the same problem for over a week.


Tried lot's of browsers but it's the same with all. I press login, the site seems to load but I get sent back to the page with the login & register product buttons again.


It's driving me crazy






Don't know if it can help...




In my case the problem is going on for months, I feel really insulted by all the customer support that provides me stupid things like resetting my password, explaining me how to do a login, asking me to provide all the info of the system/browser, etc.

I'm a software engineer, I can recognize a bug when I see one. And if I can login here, on, on US and on samsung members sites but I can't on any european site (using any browser and device I have, doing the login both with user+password or google login), this doesn't mean that I don't know how to make a login or I have cookies but that there is a bug in the european sites, probably the same source code and different by the american one.

I don't need to be helped by somebody who just read what answer to give me using the FAQs, I just need that my problem has to be forwarded to technical guys, not to call center people.

On top of that, I live in Germany, so it's even frustrating that I have to struggle to explain everything in German and then I receive always stupid answers that force me again to open another case and explain again and again everything, answer after answer my question (I copy paste and enlarge my message attempt after attempt) has become 1 or 2 pages of a Word document.

What is really insulting is after 10'000$ spent only in 2019, what I deserve is a chatbot, a person who copy paste answer from a faq or one customer service telling me that I have to contact another customer service


No one have an answer?
I cannot register my products so now I've missed the deadline
I seem to get redirected 



First Poster



I running into this issue myselft for 6 months already. Does anyone have found a solution to this problem.


I am unable to login at "" but I am able to login at ""

I am ABLE to log in into "" and see my preferences, BUT I CANNOT log in into "" .

The first time on “" it asks me for my credentials "user ID" and "password", and then the website starts to load, but it returns to the original HOME screen. Then I am unable to go into my preferences, see previous order, or see my devices, so technically I cannot see anything for my account.

I am able to login into my Personal devices (Samsung NOTE9) at the "SHOP-Samsung APP" without issues. On my phone I can see my ORDERS, REWARDS, and more BUT only on my PHONE, I cannot do that if I try to log in on “Samsung-Internet App”.

Same issue happens in Firefox, Chrome, Internet Explorer, and Samsung Internet.

It looks like I cannot log in into any web browser at "" .

I would appreciate if anyone can help me with this issue.

New Member

This has been happening to me for at least a year now. I was just now trying to claim the Pokemon GO offer that's going on in Samsung rewards when this was still happening to me: I'd log in, it would accept my credentials, then bring me to the previous page and act like I didn't just log in. Only after I logged in through, it recognized I was finally logged in by showing my name in the right-hand sidebar,  however it still would act like I wasn't logged in when I tried to click "my account" in the sidebar,  or tried to claim the offer. What fixed it for me was changing my email in When I went to sign in normally after that, it went through perfectly fine and let me claim the offer, and I can also finally view "my account" again.


Best of luck for anyone else. I've been afraid to contact customer support out of fear my account would get broken even more.

PS I am in the US, not EU.

Top Liked Authors