Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

S21 fe no esim?

(Topic created on: 11-09-2022 09:22 AM)
8784 Views
echoisland1
Apprentice
Options
Does anybody know why I don't have esim on my s21 fe or how to enable it? When I go into my settings there is no esim option only dual sim options. Is there anyway to enable it or make it appear in the settings. SM-G990B/DS snapdragon.
10 REPLIES 10
AndrewL
Moderator
Moderator
Options

@echoisland1: To enable your eSIM, please head to Settings > Connections > SIM card manager > eSIMs > + Add mobile plan, and follow the on screen prompts to complete the activation. 

0 Likes
echoisland1
Apprentice
Options
Unfortunately it's not there only the option for sim 1 and sim 2 is there anyway to make it appear?
0 Likes
Elvis Dukaj
Journeyman
Options

I have the same issue. There is no option to add a new mobile plan. I am very upset because now I cannot use the phone with my company number. 

 

0 Likes
TessM
Mastermind
Options

Hi @Elvis Dukaj and @echoisland1 ,

 

did you get your phone SIM free? Have you checked with your provider if they offer this service and how this can be enabled? 

0 Likes
Elvis Dukaj
Journeyman
Options

The phone was SIM free, and my second provider already provided me with the esim, but I have no way to register on my phone because the missing "Add mobile plan".

It really seems this feature is not supported by S21 FE, which is a real shame for such a high phone. I am considering to return it back and switch to iPhone again

0 Likes
TessM
Mastermind
Options

Have you been using this feature before @Elvis Dukaj ? You probably have done this already but would you be able to check this guide and see if any of the steps available there work for you? You can access this from here: How to use an eSIM with your Galaxy phone | Samsung UK

0 Likes
Elvis Dukaj
Journeyman
Options

@TessM thank you for the message and for trying to help! 🙏

The guide you suggested didn't help. My phone wasn't coming with any pre-assigned plan. I cannot see any installed esim. I have only one physical sim card, if I remove it there's no network.
If there was a pre-assigned plan I should be able to see it, shouldn't I?

The guide suggest:

1. Go to Settings > Connections > SIM card manager
2. Tap Add mobile plan
3. Your mobile plan will be automatically downloaded and activated on the eSIM

My problem is that I cannot do step 2. I don't have that option at all.

I don't know if I am missing something or this specific model doesn't support it!
0 Likes
TessM
Mastermind
Options

I have found a similar thread here, on our Community that indicates that this may not be available on the S21 FE yet: S21 FE 5g eSIM? - Samsung Community

 

We are always working to add new features to our devices so please keep the phone up to date to get this as soon as it gets released. 

0 Likes
Elvis Dukaj
Journeyman
Options

That's very unfortunate. The phone is not brand new, but already one year old from the release and mine is updated to the last version. Also the post is from August 2022 😕 
I expected better from Samsung. Is there anybody I can call from the Samsung support?

0 Likes