Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

iBasso TYPE-C DAC is not working in S10+

(Topic created on: 23-11-2019 08:30 PM)
19931 Views
AHHEYLI
Apprentice
Options

Hi,

 

I've tried connecting my iBasso DC02 USB Type-C DAC on my new phone Galaxy S10+, however, no USB device can be detected  (But my DAC is working on my other smartphones - Huawei mate 20 Pro and LG G5).

Already tried to select different options in the USB configuration under developer mode, but the problem persists.

 

I have to connect the DAC and restart the phone,  and it will work every time.   But once I detach the DAC and connect it back,  it fails again....................................................................................

 

Any ideas? Thanks.

 

 

0 Likes
23 REPLIES 23
ChrisM
SuperStar
Options

Hi @AHHEYLI 

 

Once the DAC is connected, does it retain a good connection without any issues until disconnected again?

0 Likes
AHHEYLI
Apprentice
Options

Yes, it works fine until disconnected.

So as a workaround now, I have to restart my S10+ every time

0 Likes
Solution
ChrisM
SuperStar
Options

That's very strange, @AHHEYLI! Unfortunately, we're not able to fully guarantee compatibility with other third party devices we're afraid, but do let us know if you have any other issues, or indeed find a solution!

0 Likes
AHHEYLI
Apprentice
Options

Thanks for the help, hope it can be supported for next version upgrade. 

0 Likes
Rubenesque
First Poster
Options

Hi AHHEYLI

 

I have the same problem but worst. I reboot my phone with my xDSD attached and powered on, but still it is not detected.

Do keep me posted if you find a solution.

 

Thanks;

0 Likes
LeoDVinci
Student
Options

Hi everyone, don't know If this is useful to anyone, but I was facing the connection issues in galaxy note 9, currently I have found a work around, not sure if that will work for everyone, but it's working for me for some time consistently. What I did is:

1.install UAC Ibasso.

2.restart.

3.connect the dc01 (it won't detect)

4.disconnect and reconnect as fast as possible.

This should prompt for default setting of Ibasso UAC

5. Each time if you need to connect doing this Connect-disconnect-reconnect as fast as possible. Worked till now for last 2 days.

Please let me know if this works for others. 

0 Likes
OllyB
Student
Options

iBasso DC02 also doesn't work with S20.

 

However if I plug the DC02 into the phone then reboot with it still plugged in, it DOES work - even without UAC Ibasso installed.

 

Frustrating, but the DC02 drives my B&W P7s beautifully.  Lovely powerful amplifier.

 

Olly

.

0 Likes
LeoDVinci
Student
Options

Sorry to hear that, actually some are saying it's some hardware issue with the USB c port in Samsung. Anyways, the process I wrote still works for me. So I stopped thinking about it 😅😅😅 hope it works for you too without restarting 

0 Likes
mister_alakista
First Poster
Options

I might have found the solution as I was running into the same thing. Do you have USB Audio Player Pro? It usually asks me if I wanted the app to control the DC02 but I tried opening it once when it didn't prompt me and it seemed to be crashing on open. I've uninstalled it along with the iBasso app and my phone is now detecting the DAC. It might be a fluke from my constant connecting and reconnecting but let me know if it works for you? 

0 Likes